Solved: Cannot Load User Dictionary - Installation Failed

Version 2

    It seemed to happen randomly and only to 3 of 30ish mac computers, but for some reason these computers started to get the annoying "Cannot load user dictionary.  Spell Checking will continue without user dictionary features."

     

    After search around the discussion board, it seemed that others that had this issue in the past and were able to re-install FileMaker to fix the issue.  So, we attempted to do just that - reinstall FileMaker on the client machine.  In that process, we got a new error, "The installation Failed.  The installer encountered an error that caused the installation to fail.  Contact the software manufacturer for assistance."  I'll opt to skip the hours and hours of headache we encountered and skip to the good news.

     

    As luck would have it one of the Machines with the issue also had Parallels installed and we also encountered an issue with Parallels... but lucky for us, Parallels offered us the answer.  This fixed both the Parallel issue and our FileMaker issue too!

    1. Start up the machine in Recovery Mode
    2. Use top menu "Utilities" and choose "Terminal"
    3. Execute this command  (note, your path may be different depending upon the name of your Hard Drive):
      1. chflags norestricted /Volumes/Macintosh\ HD/private/tmp

     

    Restart and everything worked correctly again!  I hope that helps someone else in the same situation.