AnsweredAssumed Answered

Server locks for 10-15 minutes with calculation field creation / modification

Question asked by SteveWhatman on Jul 18, 2011
Latest reply on Jul 26, 2011 by philmodjunk


Server locks for 10-15 minutes with calculation field creation / modification

Your post

Hi all,

I have a problem where filemaker server locks all records when a calculation field is created or modified for 10 to 15 minutes.

Here is the setup.

Filemaker Server Advanced running on a Xserver with a hardware raid. It is sharing out databases to approx 30 clients (all on Mac)

As an example if I modify a calculation field definition (eg a Dear Calculation that puts "Dear " or the value of another field, infront of the contacts First name, a very simple calculation) on my Macbook pro running FMP 11. I change the calculation, click ok, I am then shown a dialoug box with records remaining to be processed and OK. There are no numbers on this dialoug box.

All the other clients are locked out of the database as you would expect.

I jump across to the server and the CPU is maxed out on all 4 cores for approx 30 seconds and the elapsed time per call is growing. All good.

Then the CPU drops down to nothing, but the client is still processing records with no numbers and the server stats show the elapsed time / call and I/O time/call increasing. The Elapsed time sits around the 3000000, but have seen it peak at 15000000. It sits like this for the next 10-15 minutes, with all the clients locked out.

The database has 128,000 records and the calculation fields that I create or modify are not based on other calculations, they are straight forward text munipulation, or number crunching formulas.

I have tried doing the field change on a copy of FMP running on the server itself to see if it is a network problem. No major change the I/O numbers looked lower, but the server worked hard for 30 seconds then sat for 10 minutes with very high Elasped time figures.

The server is running PHP and XML, but has ODBC, IWP and XSLT off. The cache is set to 800MB and it hits the cache 100%.
Any help would be really appreciated.

Steve Whatman