AnsweredAssumed Answered

Why does Web Viewer not render consistently in Browse and Preview mode?

Question asked by vestigia on Mar 13, 2018
Latest reply on Mar 13, 2018 by beverly

MaOSX : 10.12.6, 10.13.3

FM        : 15.0.4, 16.0.5




For a full page layout to be printed or exported as PDF I am "desperately" trying to implement as a part of the layout a data table to show some specification content as a grid with a flexible grid ( 4 rows with 3 columns each with a label and a value cell). As the table cells have to be flexible in height the only solution to accomplish this I am using a Web Viewer object filling with appropriate HTML4 (table, tr, td) tags and formatting them with CSS2 styles.


So far this is working in general, but the details are hard to accomplish:

  • the measuring unit of point "pt" in the Web Viewer does not correspond to the measuring of the other FileMaker layout objects. "pt" dimension in the Web Viewer are greater than "pt" for other FileMaker layout objects. "pt" dimensions do also vary (slightly) in the Web Viewer object in browse- and preview mode. Even font size is changing in Browse- and preview mode.
  • fine lines (borders of table cells) in the Web Viewer object with a dimension smaller than 1pt, for examples 0.25pt are rendered correct in the browse mode but do not render correct in the preview mode. In preview mode those fine lines are rendered, by guess, with more than 1pt. Rendering results are in FileMaker 15 better than in FileMaker 16 (in FileMaker 16 this fine lines are really bold and therefor really "ugly").


Are there any hints to overcome this Web Viewer rendering problems?


Many thanks in advance and best regards,