AnsweredAssumed Answered

SMTP+GMAIL+"Sorry"

Question asked by bobtewilliger on Jul 11, 2018
Latest reply on Jul 15, 2018 by bobtewilliger

I am trying to send a pdf report to a gmail account via SMTP (through script actions). It is failing with a "There was an error with SSL" popup.

I'm sorry for having to post this up. There are so many threads, both here and elsewhere, and I've been through what I think is most of it over the past couple of days. I'm all out of ideas and am here seeking the help of the pros

 

##############################

SMTP settings:

To: "researchtaskreports@gmail.com"

Name: blank (this has been mentioned in a few places)

E-mail: "researchtaskreports@gmail.com"

Reply-to: blank (the solution is for personal use and have no need to email myself about these daily reports)

SMTP server: "smtp.gmail.com"

Port: 25 (resets to this port regardless of protocol or port selection)

Encryption: SSL

Auth: Plain password

User Name: "Filemaker Email"

Password: **:-)

 

##############################

Send Email call block:

$path == file:/D:/Documents/LabBook/DatabaseFiles/TaskReport.pdf

Get(LastError) returns "1503"

 

##############################

SavvyData SMTP Send Mail Interrogator (run multiple times with the same result):

Elapsed time: 0:17:06

 

Out of 126 iterations,

126 failed and 0 succeeded.

 

Unsuccessful count by Error#:

=============================

Error# 1501: 0

Error# 1502: 108

Error# 1503: 4

Error# 1504: 0

Error# 1505: 0

Error# 1506: 14

Error# 1507: 0

Other (not tracked): 0

 

Error# Legend:

-----------------------------------

1501 SMTP authentication failed

1502 Connection refused by SMTP server

1503 Error with SSL

1504 SMTP server requires the connection to be encrypted

1505 Specified authentication is not supported by SMTP server

1506 Email(s) could not be sent successfully

1507 Unable to log in to the SMTP server

 

##############################

Platform:

Windows 7, 64-bit

FMP Advanced v15.0.1.119

Allow less trusted apps has been activated in gmail

##############################

 

There appears to be something quite wrong with the setup somewhere as I'm not even getting 'attempted access' emails from google. I have also confirmed that the pdf is generated and in the predetermined location.

 

If there are more screenshots or info required to try and resolve this I'm more than happy to help you help me

 

Cheers

Outcomes