AnsweredAssumed Answered

Performance issues

Question asked by Swedenborg on Oct 11, 2018
Latest reply on Oct 12, 2018 by Swedenborg

Hi.

 

We are having troubles with users that are experiencing unreasonably long response times. The problem occurs from time to time during the day and lasts from minutes and longer until it stops, or the user force quits their FileMaker client.

 

Server 16.0.4 in running on Windows 2016 Datacenter (4C/8Gb) and clients are mixed Mac and Windows on 16.0.4 (and a few 17.0.2) All access i over WAN. Resource Monitor does not seem show a unreasonable CPU or memory pressure. The problem occurs for user on different locations and networks.

 

The solution has run for year without these problems but now they seem to be slowly increasing over time.

 

Worth mentioning:

 

  • ESS in in use server side but just rarely used to fetch a record or two or to update something i sql
  • One table has tens of thousands remotely stored container files. (Open storage.)
  • User work mostly on one detail layout and problem seems to start randomly whenever clicking something, and not in conjunction with data heavy operations

 

We have read the tread Server 16.0.3 'hangs' with great interest and started to look at the Top Call log file. I am attaching a sample from this log that shows a certain area that caught our attention:

 

There are are numerous lines for the operation "Query (Find)" – often several at one – and a table with id 143 is showing up more than expected. These entries also have a significant high number in the Total Elapsed column. Why all these "queries"? See records 437-669 in the log file. All the records are generated by myself, and that surprises since I did not do anything but wait for the pinwheel to stop turning for several minutes during this time...

 

Any thoughts on what might cause all these entries and if it might be related to the problems we are having?

 

This table with id 143 is the one with all the remote container data. Number of records > 60.000 . The data from this table is show in a sorted portal on the mention detail layout. Number of records in this portal is typically 5-15 records per parent record. The portal sort is referring to un-stored calc fields, but when actually sorting there is no performance issues, and as mention, the problem does not occur more often when a user interacts with this portal (that is on a separate tab) than with anything else.

 

Any help would be highly appreciated.

 

Thanks

Niklas

 

P.S. Sometime the "Find in progress" dialog shows for no apparent reason. (Also attached.)

Outcomes