5 Replies Latest reply on Jan 21, 2009 11:50 AM by ninja

    File Printing Problem...

    RickJensen

      Title

      File Printing Problem...

      Post

      We just upgraded to FMPro 9, we were running 5 before.  The file we converted has a Print button in it, and it doesn't work quite right anymore.  The document in the file is 1 page long and when you go to File, Print, it prints out on one page.  If you hit the print button in the document, it wraps the last line of the document onto a second page.  Does anyone have any ideas on how to fix this?  I have no familiarity whatsoever with this software so anything will help...Thanks!

        • 1. Re: File Printing Problem...
          ninja
            

          howdy RickJensen,

          Thanks for the post.

           

          Go into layout mode (under {View} dropdown)

          Right click on the button in question and select Button Setup (or double click on the button)

          It should open a box that will either have "Perform Script" or "Print" selected on the left column.

           

          If it's "Print", look under "specify print options" and make sure everything looks in order as compared to your manual printing that you say works alright.

           

          If it's "Perform Script", click "Specify" and find out which script it runs.  If you know your way around in scripts, check for "Print Setup" within the script to accomplish the same thing as your manual setup.  you would check into the script under the {Script//Scriptmaker} dropdown in layout mode.

           

          Note: If the script is more than a couple of steps in the big right-hand pane, then BE CAREFUL.  If this script is doing a bunch of stuff besides just printing, and if you have no familiarity with the software, you can break something pretty easily when in Scriptmaker.  When you want out of the scriptmaker box, be sure to "Cancel" rather than "OK" if you're unsure.

           

          Please post back and give an update...

          • 2. Re: File Printing Problem...
            RickJensen
              

            Ninja,

             

            Thank you for the response.  I checked the button settings and it is running a script.  I looked at the script and the print settings inside it and they all match.  I did a test print using the button and going File > Print and examined the documents, and believe I have found the culprit but do not know how it is getting there or why. 

             

            The last line in the document is a Signature and Date line.  If you print it using File > Print, it prints off normally.  If you use the print button, it puts a large "}" between the Date line and the Signature line.  This bracket is not shown in the document on the screen.  Any ideas or suggestions here?  Thanks again!

             

            RJ

            • 3. Re: File Printing Problem...
              ninja
                

              Rick,

               

              There are two ways to go...figure it out and finesse a solution.  Or override what is going on.

               

              Override = replace the "Print Setup" and "Print" functions in the script with the script command "Print" and be done with it.  If File>Print works, then Script>Print should work as well.

               

              Finesse = figure out what else the script is doing, figure out where and why that character is appearing and how to remove or avoid it.

               

              I cannot see the script you see.  If it were me, I would add a single line to the script as a trial...inserting the "Print" command as the first script line and then trying it.  If this worked, I would remove the second "Print" command and leave the rest of the script alone.  I would do it this way because I am unfamiliar with the rest of the database workings and this would not disturb any other features.  Especially if you are very UNfamiliar with FMP as you've mentioned.

              If this did not work, then there would be more digging to do.

               

              If the whole of your script is "Print Setup" followed by "Print"...don't worry about breaking stuff.  If there are any "GotoLayout" or "SetField" or IF[] statements or the like, they should not be disturbed or rearranged.

               

              Please let us know how you fare.

              • 4. Re: File Printing Problem...
                RickJensen
                  

                Ninja,

                 

                The script is doing more than just printing so overriding I don't believe will work.  Here is the script:

                 

                Print Setup [Restore; No dialog]

                Print [Restore; No dialog]

                Go to Layout ["INVOICE" (civil)]

                Refresh Window []

                Print [No Dialog]

                Got to Layout ["SHERIFF RETURNS" (civil)]

                Refresh Window []

                Go to Field [civil::COPY]

                Insert Text ["COPY"]

                Print [No dialog]

                Clear [Select; civil::COPY]

                 

                Does this help any?  I appreciate everything!

                • 5. Re: File Printing Problem...
                  ninja
                    

                  Rick,

                   

                  Your script prints the active record, a related Invoice, and a "Sheriff Return" marked with the word COPY on it.

                   ...and you mention that just hitting "Print" works just fine and prints out the active record appropriately.

                   

                  Before taking out the "Print Setup" step, do my overly-cautious-self a favor and move the first "Print [Restore; No dialog]" up one step so that it is above the "Print setup" step.

                   

                  Then use the button in Browse mode.

                   

                  If it prints nice, then go back in and remove the "Print setup" step altogether.  If it still doesn't print correctly, then I'm not sure where to go.  The issue is clearly in the print setup otherwise your File>Print would give you a weird print as well.

                   

                  And just checking...the other two pages I referece above are printing out appropriately as well...Right?!? 

                   

                  Enjoy the day!