4 Replies Latest reply on Jul 14, 2011 7:47 AM by GeoffreyMartin

    file too big?!

    GeoffreyMartin

      Title

      file too big?!

      Post

      Hello all,

      I was wondering if there is a known bug or limit to file size on Filemaker 11 files.  The magic number tends to be around 4.5 Gb.  Under that I can copy it onto a flashdrive or any other drive.  Larger than that and the system tells me that the disk is not large enough.  It's a windows machine running XP, I've tried it with an empty 750 Gb drive, a freshly formatted 15 Gb flash drive.  I get the error whether I try to copy the file from the windows operating system or from saving a copy from within filemaker.  Has any one else had this problem??

      -Geoff

      error1.PNG

        • 1. Re: file too big?!
          TSDuck

          Hi Geoffrey Martin:

          Thanks for posting.

          Currently, FileMaker database sizes are limited only by remaining disk space, up to a maximum of 8 terabytes.  A FileMaker database of 4.5 GB should be able to copy over onto a flash or external hard drive.

          What is the processor speed and RAM on your Windows XP machine?

          What folder is your database stored in?

          What is the exact error message that you are getting?

          Do you have any other non-filemaker files that are larger then 4.5GB?  Could you try copying this file through Windows onto your external device?  If large non-filemaker files get the same error, it could indicate a system or OS issue.

          I would also suggest testing a different FileMaker database.  In FileMaker, create a new database file.  Under the file menu, go to manage and database.  Under the fields tab, create a field called container, set to type container.  Right click the container on your layout and choose either insert picture or file.  Now select a large file, make sure store only a reference is unchecked, and click open to insert the file.  Click the new record button from the status bar, and continue adding large files until you reach a database of 4.5 GB in size.  Try copying this new file to your external device and see if the error occurs.

          TSDuck

          FileMaker, Inc.

          • 2. Re: file too big?!
            aammondd

            Check the File System of your system on your computer if its not NTFS (some early XP systems could be running FAT32) it may be limiting the file size.

            You can check the the file system by right clicking and selecting properties on the drive.

             

            • 3. Re: file too big?!
              GeoffreyMartin

              I'm running the lastest update of Filemaker Pro Advanced 11 on a DELL AMD ATHLON DUAL CORE 2.3 Ghz with 3.25 Gb of memory.  The OS is Windows XP Pro v2002 Service Pack 3, (XP Professional 5.1.2600).  The USB stick's file system is FAT32 and the C drive is NTFS.  The file is located in a folder on the desktop called LCATS.

               

              • 4. Re: file too big?!
                GeoffreyMartin

                Couldn't reformat the USB stick to NTFS so I found a link http://forums.hexus.net/corsair-care-hexus/145634-how-remove-file-size-limit-8gb-corsair-usb-stick.html.  Told me how to do it and I've solved the problem.  Thanks for steering me in the right direction.  It is copying as we speak.

                -Geoff