10 Replies Latest reply on Nov 2, 2009 8:49 AM by steve4640_1

    FileMaker Pro 10 with Entourage

    WilliamLackey

      Title

      FileMaker Pro 10 with Entourage

      Post

      Hi All,

       

      My script for sending email via Client does not seem to be working with Entourage any suggestions?''

       

      Thanks,

        • 1. Re: FileMaker Pro 10 with Entourage
          TSGal

          William Lackey:

           

          Thank you for your post.

           

          What occurs during the Send Mail script step?  Does it crash?  Do you receive an error message?  Does nothing happen?

           

          Assuming Entourage is not your default Email application, do the following:

           

          For Mac OS X, launch Entourage, pull down the Entourage menu and select "Preferences".  Click the "General" icon and set the "Default email reader".

           

          For Windows, go into the Control Panel, click on "Set Program Access and Defaults" on the left side, select "Custom" and "Choose a default e-mail program".  Make sure you also check "Enable access to this program".

           

          Close the settings and relaunch FileMaker Pro.

           

          Pull down the File menu and select "Send Mail...", and send a test email to yourself.  If this works, then try the script again.  If this doesn't work, does Entourage at least launch?

           

          TSGal

          FileMaker, Inc.

          • 2. Re: FileMaker Pro 10 with Entourage
            WilliamLackey
               <!--  StartFragment  -->

            Hi TSGal! Thank you for your assistance!

             

            Entourage does launch but a new e-mail will not send.

             

            In the send mail section of the FileMaker I am have databeing retrieved from a Subject and Message field.

             

            I hit a send button that I have created linked to the scrip,Entourage will startup but an e-mail with the data retrieved from the specifiedfield will not appear.

             

            Thanks,

            Billy

            <!--  EndFragment  -->
            • 3. Re: FileMaker Pro 10 with Entourage
              WilliamLackey
                

              Sorry new e-mail will not send.

               

              • 4. Re: FileMaker Pro 10 with Entourage
                philmodjunk
                  

                Just a friendly hint:

                 

                If you spot typos in your post after you post it, you can edit your post by selecting  the appropriate option from the options menu (just above the yellow kudos control) in the upper right hand corner of your posted message. :smileywink:

                • 5. Re: FileMaker Pro 10 with Entourage
                  WilliamLackey
                     Thank you!
                  • 6. Re: FileMaker Pro 10 with Entourage
                    davidanders
                      

                    This is a list of links for Filemaker to Email Plugins and Scripts

                    http://www.cnet.com/topic-software/e-mail/filemaker-inc.html 

                     

                    You may find it helpful.

                    David Anders 

                    • 7. Re: FileMaker Pro 10 with Entourage
                      steve4640_1
                        

                      Yep, I've got this same problem, in FileMaker 10, Send Mail works off of File > Send Mail, but when running from a simple script to do the same thing, only brings Entourage to the front, without placing any email in the Outbox.

                       

                      I've seen several posts describing this problem here, but no resolution to the problem yet.

                       

                      Does anyone have a solution?

                       

                      Thanks!

                       

                      Steve 

                      • 8. Re: FileMaker Pro 10 with Entourage
                        TSGal

                        steve4640:

                         

                        Thank you for your post.

                         

                        Sorry.  No solution at this time as I am unable to reproduce.

                         

                        As I look over customer calls from the past five years, I found a similar instance from a customer with FileMaker Pro 8 and Entourage.  The initial report was that the email was not being created, but after further testing, it was being put in the Drafts folder.  There was no solution mentioned from that case.

                         

                        Also, a customer could not send emails using the Rosetta version of Entourage.  This also occurred during FileMaker Pro 8 timeframe.

                         

                        I'm trying to locate a computer that uses Entourage.  In the mean time, if anybody is using Entourage and FileMaker Pro successfully, please let us know.

                         

                        TSGal

                        FileMaker, Inc. 

                        • 9. Re: FileMaker Pro 10 with Entourage
                          TSGal

                          All:

                           

                          I was finally able to get a obtain and install a copy of Entourage (2008 - Version 12.2.0 with latest installed update 12.2.1).  I set this to be the default email program (under Preferences).  I then launched FileMaker Pro 10.0v3, pulled down the File menu and selected "Send Mail...", addressed it to myself and sent it.  No problem.  It was sent immediately.

                           

                          I then created a script to Send Mail, checked the option to "Perform without dialog", and specified E-mail Client, sent to myself, etc.  When I run the script, the mail is sent automatically.

                           

                          The only way I can duplicate the problem is if I uncheck "Perform without dialog", as this would obviously just bring up the email message (and not send it).

                           

                          TSGal

                          FileMaker, Inc. 

                          • 10. Re: FileMaker Pro 10 with Entourage
                            steve4640_1
                               Yes, this confirms my experience. What was throwing me off was that the Perform without Dialog box was unchecked by default. But it all works fine now!