0 Replies Latest reply on Jun 17, 2013 10:11 PM by AmitChoudhari

    FileMaker Pro 12v4 ODBC / JDBC client:   Unable to connect to FileMaker files on Windows XP (SP3)

    AmitChoudhari

      Title

      FileMaker Pro 12v4 ODBC / JDBC client:   Unable to connect to FileMaker files on Windows XP (SP3)

      Post

           We are using FileMaker Pro 12v4 and would like to use JDBC client to read / write data to FileMaker DB file. The FileMaker DB and JDBC client both are running on the same machine.

           For some reason whenever we try to connect to FileMaker using JDBC client running on same PC, the client process hangs i.e. it stops responding after few seconds. No error is thrown by the Java code.

           We are having this issue on Windows XP (SP3) environment and on Windows 7 it seems to be working fine.

           We also tried to use the ODBC client provided with the FileMaker and similar problem exist for ODBC client also. After installing the ODBC client, when we tried to connect to FileMaker DB using the client it stops responding as soon as it tries to connect to FileMaker DB. ODBC client and FileMaker are running on the same machine.

           Here are the steps that we are following to run FIleMake and use JDBC client:

           1. Install FileMaker Pro 12v4 on a Windows XP (SP3) machine.

           2. Open a FileMaker DB file.

           3. Set the ODBC / JDBC sharing option for the DB file.

           4. Follow the steps listed in the document: "fm12_odbc_jdbc_guide_en.pdf" to run a simple test Java client. The client is running on the same machine as FileMaker Pro. We picked the "fmjdbc.jar" from the directory which was created by extracting the FileMaker Pro 12v4 installation file.

           5. Run the Java program (using JDK 6) and it just hangs without any error.

           We also tried using the ODBC client setup as listed in the document: "fm12_odbc_jdbc_guide_en.pdf". and got similar issue while configuring DSN on the step where ODBC client tries to conect to FileMaker DB.

           As soon as we set the ODBC / JDBC sharing option the xDBC process appears in the Windows Task Manager so the listener process seems to be running and we also checked the port number for the listener process (using netstat) and it is running on 2399 port.

           I am not sure if I am missing any step in the setup. Somehow same process is working fine on Windows 7.

           Any help on this probem would be appreciated.

           Thanks in Advance.