7 Replies Latest reply on Apr 17, 2010 7:05 AM by levdtrotsky

    Filemaker ten checkboxes

      Title

      Filemaker ten checkboxes

      Post

      Howdy.

       

      I'm using FileMaker Pro 10, and and creating databases with checkboxes. While I was doing that this evening, for the first time, the checkboxes disappeared, not on the old fields, but on the new ones. It's still possible to make a check, but there is no box to check.

       

      I presume I managed to mess up a setting somewhere; can anybody tell me how to fix this?

       

      Thank you very much.

       

      - levdtrotsky

       

      PS: "FileMaker" and "checkbox' are not recognized as correctly spelled words by the spell check software on this website ??!!

        • 1. Re: Filemaker ten checkboxes

          To be clear, I am on a Mac running 10.6.3 and have been using Filemaker since it was Claris, but only for a fairly simple database (a bibliography).

           

          - levdtrotsky

          • 2. Re: Filemaker ten checkboxes
            arnoldkegebein

            I am not sure if I understand your problem ("It's still possible to make a check, but there is no box to check."), but it sounds you run into something I experienced a couple of times with FM10. I assume you were in layout mode and the statusbar was closed. When you open the statusbar, all layout objects are pushed down to make room for the statusbar (expected). But sometimes internally FileMaker thinks, the objects are still in the old places. You click an object, but the little black boxes around the selected objects are displayed some distance above the visible object. My work-around in this situation: manual change the window size. This makes FileMakers refreshes the screen and the internally object positions.

            • 3. Re: Filemaker ten checkboxes
              hbrendel

              Look at "Field Borders". Menu Format > Field/Control > Borders...

              • 4. Re: Filemaker ten checkboxes
                LaRetta_1

                Hi levdtrotsky,

                 

                "It's still possible to make a check, but there is no box to check."

                 

                If you are seeing the checks but not the box, it could be: 

                 

                1) Pen Pattern is set to transparent (make sure selection is not top left pattern box but rather the top second box)

                2) Make sure your pen width is at least 1 px.

                 

                If your pen color is set to background color, the box would disappear but so would the checks themselves.

                • 5. Re: Filemaker ten checkboxes

                  LaRetta:

                   

                  This sounds like exactly what I need. But I can't find the "pen pattern" control even using Filemaker help. Can you tell me where it is?

                   

                  - LDTrotsky

                  • 6. Re: Filemaker ten checkboxes
                    LaRetta_1

                    A few ways to get there:

                     

                    With status area (now called status toolbar) showing, the pen controls are the bottom set of tools (two on the right).  You can also select the field, right-click, and select pen controls there. 

                     

                    UPDATE:  In FileMaker Help, it can be found if searching for "Setting color, pattern, line width, and object effects"

                    • 7. Re: Filemaker ten checkboxes

                      Thank you very much!! All of you!!

                       

                      I went back to field controls >  borders and started to play with the controls, and stumbled across the correct settings.

                       

                      What I should have done, immediately, was to check those controls on one of the boxes that was behaving itself, and then I would have known what the right settings were . . .

                       

                      I have no idea how I managed to mess them up, but there you go.

                       

                      Problem solved using field controls>borders; thanks to everyone for their contributions; three lashes with a wet noodle to me for not "back engineering" in the first place.

                       

                      - levdtrotsky