5 Replies Latest reply on Aug 5, 2015 1:10 AM by LauraJones

    Find not working

    LauraJones

      Title

      Find not working

      Post

      I am trying to perform a simple find by putting the numbers 25 into a field that I know should bring up at least 30 records containing that number (25 is the start of a 6 digit code). I've done this in several ways, using "25", 25, *"25* and none of them work. I then tried to enter the entire code of a record that again I know exists but I am still getting the message that no records match the criteria. Does anyone know what might be going wrong? 

        • 1. Re: Find not working
          bokenrosie

          Did you try the # character for each digit?  If using a text field for the number you might need this.  

          # finds but not 30
          ## finds 30 but not or 300
          #3 finds 53 and 43 but not 3
          • 2. Re: Find not working
            philmodjunk

            When I open the Known Bugs List database (https://www.dropbox.com/s/jt09b82i0xijbu3/FMP%20Bugs.zip) and use *8* as find criteria in the BugID field on the FMP Bugs layout, I find such records number 8, 18, 78, 81 to name just a few so I'm not sure why this didn't work for you.

            What is the data type of this field?

            Is the field formatted as an edit box or with a value list?

            Is this a manual find or in a script?

            What version of FileMaker are you using?

            • 3. Re: Find not working
              LauraJones

              The field is a number edit box and I am using a manual find on Filemaker 13. One thing I have noticed is that the matching field in another table is set to text rather than number and that field performs the find without any problems. I could just switch the field to text but why is the find not working for a number edit box?

              • 4. Re: Find not working
                philmodjunk

                It's not clear at this point. The test that I originally ran was on a field of type number, but the file was open in FileMaker 14.

                So I just ran this again on a file open in FileMaker 13. I had one field of type text and one field of type number with identical characters in both fields of the same record in each case.

                using this find criteria (note that I am not using quotes here):

                *25*

                in either field produced identical results. I had three records with the values:
                342567
                432589
                458992

                The find found the first two records and omitted the third whether I put the criteria in the number or the text field.

                One more question: Is this field from the same table occurrence as that of the layout? (If you check "display data from" in the inspector, do you see exactly the same text to the left of :: as you see in "show records from" in layout setup?)

                • 5. Re: Find not working
                  LauraJones

                  Hi, 

                  I've tried it again today with the * either side and it is now working. Thank you for your help.