2 Replies Latest reply on Nov 1, 2013 8:53 AM by CaitlinMcKelvie

    Find/ Quick Find Not Working on a field that is also a button

    CaitlinMcKelvie

      Title

      Find/ Quick Find Not Working on a field that is also a button

      Post

           I currently have a layout and scripts set up very similarly to the PersonPicker from the Meeting sample database that is given with FIleMaker Pro 12. On my PersonPicker layout, I am trying to select people to add to a class they have attended. Everything with my layout and scripts works fine. I can select a person on the picker and it adds them to the class appropriately. There is a field on the layout that shows a members First Name Last Name City and State. This field serves as a button that gets selected and then adds the person to the class. However, the problem is that once I import all of our members into the database, we will have over 12,000 members. This makes it very difficult to add members to the class just by scrolling through. When I have tried using quick find (the layout has a field with a script that should do a quick find on it and I have also tried using the regular quick find field), or when I have tried to perform a find, it says that there are no results, when there should be. I think that the problem is that the field is a button because you click on it to select a member, so it doesn't search the field. What can I do to remedy this?

           My other question is that my PersonPicker pops up in a new window. This new window doesn't allow for a find or a quick find, even though I don't have them disabled. Why is this? The first part of this won't matter if I can't do a find on the layout when it opens up into a new window.