3 Replies Latest reply on Dec 21, 2009 8:16 AM by philmodjunk

    FM 10 Web Publishing Not Saving Upon Submit

    MauiDave

      Title

      FM 10 Web Publishing Not Saving Upon Submit

      Post

      Using FMP 10. DB saves field data fine, but on the browser (when using web publishing) we enter data but it doesn't save it when the "Submit" button is pressed. It just returns the page without the changes. It used to work. Thank you in advance.

        • 1. Re: FM 10 Web Publishing Not Saving Upon Submit
          TSGal

          Maui Dave:

           

          Thank you for your post.

           

          Can you tell me more about the fields?  Text?  Number?  Portals?

           

          Do all fields not save the data, or just a select group?

           

          Do your account privileges allow you to make changes? 

           

          Create a second layout with some of the same fields.  Go into Instant Web Publishing and see if you are able to enter data into this new layout?  If so, then the original layout may be corrupt.  Try removing one of the fields and drag the replacement onto the layout.  Does this work?

           

          Any detailed information you can provide may be helpful in determining a possible cause.

           

          TSGal

          FileMaker, Inc. 

          • 2. Re: FM 10 Web Publishing Not Saving Upon Submit
            MauiDave
              

            Can you tell me more about the fields?  Text?  Number?  Portals?

            **TEXT**

             

            Do all fields not save the data, or just a select group?

            **JUST A COUPLE**

             

            Do your account privileges allow you to make changes? 

            **YES**

             

            Create a second layout with some of the same fields.  Go into Instant Web Publishing and see if you are able to enter data into this new layout?  If so, then the original layout may be corrupt.  Try removing one of the fields and drag the replacement onto the layout.  Does this work?

            **I JUST ADDED A NEW TEXT FIELD. I CANNOT "SUBMIT/SAVE" DATA IN THIS FIELD IN MY BROWSER (BUT CAN ON THE HOST MACHINE). OTHER FIELDS WORK FINE. I TRIED COMPARING SETUP BETWEEN FIELDS AND THEY ARE EXACTLY THE SAME.

             

            Any detailed information you can provide may be helpful in determining a possible cause.

             

            TSGal

            FileMaker, Inc. 

            • 3. Re: FM 10 Web Publishing Not Saving Upon Submit
              philmodjunk
                

              This is where you should investigate further:

               

              Do all fields not save the data, or just a select group?

              **JUST A COUPLE**

               

              What's different about those few fields that don't update? Are they all from a different table than fields that do update? If so, check out the relationship linking these tables to see if there might be a clue there as to why they didn't update.