3 Replies Latest reply on Jan 7, 2011 4:00 PM by fabricen

    FM Not Really Deleting a Portal Record

    lloyddd

      Title

      FM Not Really Deleting a Portal Record

      Post

      I am starting to feel the need for a good exorcist with my recent issues.  Has anybody else encountered this?

      PROBLEM: User clicks on button in a portal row with a single "Delete Portal Row" command.  Portal row does not dissappear and record appears to remain.  Portal is setup to allow the deletion of portal records and user has privlages to delete record.

      Going to the related table shows that the record is missing and the full record count is one less than before the "Delete Portal Row".  However, if I run a find by the deleted records serial number it comes up.  Show all it dissapears and FM does not count it as a record.  Happens with full access.

      Kind of baffled on this.

      FM11 Advanced Windows and Mac
      Database is hosted on FM server.

        • 1. Re: FM Not Really Deleting a Portal Record
          philmodjunk

          You've definitely got something screwy going on.

          Is this a straight one to many relationship between the layout's record and the portal table?

          No "in between" tables or a many to many relationship?

          If it's a simple straight one to many relationship, I'd check the file for damage. You might re-index the portal table's serial number field. You might run the recover action on the file and test the recovered copy (even if no problems where found) to see if it works. If you recover the file, best practice is not to use the recovered file. If file was damaged, replace it with an undamaged copy if at all possible.

          • 2. Re: FM Not Really Deleting a Portal Record
            lloyddd
            Yep it is a vanilla 1-many. No damage in my first check and re-indexing appears to have worked.  I'm going to keep an eye on it.  Phil, you've been responsive to all my issues the past 24 hours.  Many thanks.
            • 3. Re: FM Not Really Deleting a Portal Record
              fabricen

              Hi, just to report the exact same problem.

              I have 2 equivalent relationships, and a portal for each. In the first portal, a Delete portal row button works smoothly. Not in the second one.

              If I use a script to spy an error number, it shows no error.

              So I change to a GTRR/Delete Record script, and it works.