1 Reply Latest reply on Feb 20, 2009 10:07 AM by TSGal

    FM Pro Advanced 10-scripting issue

    RickWhitelaw

      Title

      FM Pro Advanced 10-scripting issue

      Post

      Hi,

       

      This is the second time I encountered this situation. The first time involved a long series of scripts and sub-scripts and involved several files. The script debugged just fine but returned a lot of "?"s in real time. I believe it was TsGal who suggested inserting a pause. I tried this and it worked. The pause is now defined as .1 seconds and therefore adds 1 second for every 10 records processed since the pause itself is within a loop.

          This time it's different. A very simple script in another file is being invoked by a menu item. It's being passed one script parameter. It was debugging fine but when invoked in real time nothing happened . . . no errors . . . nothing. I then inserted a .1 second pause after the first step (Go to layout) of the script involved and it works just fine. Obviously .1 seconds is pretty imperceptible especially since the script isn't recursive. I find this odd. In the first instance the script dealt with many records and complex calculations. A pause might be seen as justifiable if only to allow for the difference between processor speed and bus speed. In the second instance the script is performing a quite simple set of tasks but the .1 second pause makes all the difference.

          Ideas?

       

      RW 

        • 1. Re: FM Pro Advanced 10-scripting issue
          TSGal

          RickWhitelaw:

           

          Thank you for your post.

           

          I don't have any immediate ideas, but I would like to see the file (if possible).  I have sent you a private message (top of this page - right side - just below the blue bar - X Messages) with instructions where to send the file.

           

          TSGal

          FileMaker, Inc.