12 Replies Latest reply on Mar 13, 2009 6:01 PM by k2qo_1

    FM10Pro / IWP / Going CRAZY!

    k2qo_1

      Title

      FM10Pro / IWP / Going CRAZY!

      Post

      Hi Gang,

       

      I upgraded to FM Pro 10 and downloaded the IWP update. My goal is to access a small DB remotely from 2 remote sites. The setup is thus:

       

      2 newer iMacs running 10.5.6 wired to an ActionTec modem/router which is fed by FiOS. I've instructed the router to forward ports 591 and 80 to the iMac with FM. In FM I've enabled file sharing, and IWP on port 591. So, this address is 98.67.xxx.xxx and my iMac has a static IP of 192.168.1.xxx. So far so good.

       

      Now, when I type 98.67.xxx.xxx:591 into my web browser on any of the remote machines which are on other networks across the internet, I get a progress bar that hangs and never connect. 

       

      I have Remote Desktop access to the computer with the DB so I can make all necessary changes and test from my MacBook Pro. 

       

      Any ideas?

       

      Thanks,

      Mark

      Clarence, NY 

        • 1. Re: FM10Pro / IWP / Going CRAZY!
          fitch
            

          Did you set up a privilege set with the IWP extended privileges enabled?

           

          Have you tested it on your local machine to make sure the file can be accessed via IWP?

          • 2. Re: FM10Pro / IWP / Going CRAZY!
            k2qo_1
              

            Hi Tom,

             

             

            Thanks. I do have the IWP privileges set and the IWP extended is OK too.

             

            The one thing I did not do was to test it from the other machine on the same network. I'll try that!

             

            Mark 

            • 3. Re: FM10Pro / IWP / Going CRAZY!
              k2qo_1
                

              Another piece of the puzzle. If I try to share the same DB on my 2.0 GHz G5 iMac, I have even more troubles. As soon as I click the button to turn on IWP, the spinning beach ball comes on and I have to force quit the applicaiton. The G5 has the 10.0.1 update. I'm getting really frustrated!! This machine is on TWC Roadrunner, their cable modem and my Airport Extreme. I've checked all of my sharing setting, AE settings, etc. Something is wrong, but what?

               

              Mark

              Clarence, NY 

              • 4. Re: FM10Pro / IWP / Going CRAZY!
                TSGal

                k2qo:

                 

                Thank you for your post.

                 

                Let's start simply:

                 

                1. Launch FileMaker Pro.

                2. Open a local database file.

                3. Pull down the File menu and select "Sharing -> Instant Web Publishing..."

                4. Turn on Instant Web Publishing.

                5. Write down the IP address.

                6. In the lower left of the Instant Web Publishing dialog box, highlight the local file

                7. In the lower right of the dialog box, set the access to "All Users"

                8. Click OK.

                9. Go to another machine, open a browser, and enter the IP address written down in step #5 above.

                 

                If Instant Web Publishing doesn't start in step #4 above, then you have a port conflict.  Change the port configuration to 591, which is registered and reserved for FileMaker Pro.

                 

                If this works, then start making your changes and see which change affects Instant Web Publishing.

                 

                TSGal

                FileMaker, Inc. 

                 

                On any of the machines, launch FileMaker Pro along with a local database file. 

                • 5. Re: FM10Pro / IWP / Going CRAZY!
                  k2qo_1
                    

                  TS Gal,

                   

                  I followed these instructions and had success. Both machines were on 125.205.xxx.xx, so the same subnet. I then accessed the db from a wired desktop behind a firewall with an address of 125.205.yy.xx. It worked. I then asked someone 35 miles away on 66.67.xxx.xxx to try it and NO GO. They could not gain access. The machine running FM10Pro was set for port 591 and this was appended to the IPs as required for access.

                   

                  Again, the setup I need to work is (file is hosted on the first iMac):

                   

                  (FM10Pro/new iMac/Static internal IP)---wired----(Actiontec WR424 Router/Port 591 forwarded, Verizon FiOS)-------((INTERNET))---------------(TWC/Cable Modem)--(Airport Extreme)----wired----(iMac G5/Static internal IP)

                   

                  Thanks,

                  Mark 

                  • 6. Re: FM10Pro / IWP / Going CRAZY!
                    TSGal

                    k2qo:

                     

                    Good!  We are a lot closer.

                     

                    The 125.205.xx.xx is in the same subnet, so I bet port 591 is being blocked.  Can you verify?

                     

                    TSGal

                    FileMaker, Inc. 

                    • 7. Re: FM10Pro / IWP / Going CRAZY!
                      TSGal

                      I should be a little more specific....

                       

                      Make sure that both TCP and UDP ports are open and port 591 is open.

                       

                      TSGal

                      FileMaker, Inc.

                      • 8. Re: FM10Pro / IWP / Going CRAZY!
                        k2qo_1
                          

                        TS Gal,

                         

                        I've set the Actiontec router to forward TCP and UDP on Port 591. When I try to access this computer from another network I still get "cannot connect". Yes, I am appending :591 after the 98.117.xx.xx. Still no luck.

                         

                        I am considering resetting the router to factory settings and starting over.

                         

                        Mark 

                        • 9. Re: FM10Pro / IWP / Going CRAZY!
                          k2qo_1
                            

                          TS Gal,

                           

                          THANKS!! 

                           

                          FIRST HURDLE ACHIEVED! I am now successfully connecting to may database. It is hosted on an iMac behind the FiOS equipment (to which I have Apple Remote Desktop control) while I can work with the data from my computers miles away behind the TWC system.

                           

                          The thing that actually made this work was getting the Actiontec setup right. When forwarding TCP and UDP ports to a specific local address, you have to say Any-->591, not 591-->591 for both entries.  

                           

                          My other rub is this.  I'd really like to run this in reverse. Host the db on my G5 iMac on my home router behind the Airport Extreme. When I try to setup the router I cannot select All-->591 for UDP and TCP. The AE requires actual port numbers. So my entries are 591-->591. But regardless of what numbers I use, Filemaker 10.0v1 crashes when I hit the radio button to turn on IWP.

                           

                          I can set IWP OK on my Intel MacBookPro on this network but that is no good for obvious reasons.

                           

                          Any more ideas??

                           

                          Thanks,

                          Mark 

                          • 10. Re: FM10Pro / IWP / Going CRAZY!
                            TSGal

                            k2qo:

                             

                            It sounds like you have everything set up correctly.

                             

                            After talking this over with another technician, two possibilities come to mind.

                             

                            First, disconnect from the network and see if you can turn on Instant Web Publishing.  (You should be able to).  If not, then there may be a permissions error.

                             

                            Next, create a new user account on the machine.  Log onto that new user account, launch FileMaker Pro and turn on Instant Web Publishing.  If this works, then reconnect the network and try again.  If this works, then there is something wrong with the initial user account and/or preferences.

                             

                            This has us stumped, so please continue to keep us posted.

                             

                            TSGal

                            FileMaker, Inc. 

                            • 11. Re: FM10Pro / IWP / Going CRAZY!
                              k2qo_1
                                

                              TS Gal,

                               

                              I will do that tonight when I get home. But FWIW, I did try to turn on IWP from 2 different accounts on the G5, and from both 8.5Pro and 10Pro all with the same beach ball of death. I did not try with the ethernet cable unplugged.

                               

                              Nothing like a real Geek Challenge!

                               

                              Mark 

                              • 12. Re: FM10Pro / IWP / Going CRAZY!
                                k2qo_1
                                  

                                TS Gal and Gang,

                                 

                                It all works!! Why? That is a good question. I repaired permissions on the G5 and tried again. No go. FM would not publish. I then deleted and rebuilt all of the permissions. Tried again. Would not publish. It said that I had a port conflict. I changed the port to 591 from 80 and still got the conflict message. I changed the port to 592 in FM Pro and and then made sure my forwarding in the Airport Extreme was set correctly. 

                                 

                                I then tried to access the db from outside my home network and SHAAZAAM! Works great. I believe that there were 2 problems. The privileges were nutzed up somehow and ports 591 and 5003 would not work with my AE. 

                                 

                                Thanks to all for the help. This was one hell of a learning experience.

                                 

                                Best regards,

                                Mark

                                Clarence, NY