3 Replies Latest reply on Jul 23, 2012 1:13 PM by davidanders

    FM12 Pro Adv IWP Not Showing Databases

    JoeCoon

      Title

      FM12 Pro Adv IWP Not Showing Databases

      Post

      Hello There,

      I recently did an upgrade from FM 10 Pro Adv to FM12 Pro Adv and I am having some difficulties in getting the IWP to show my databases.

      Mac OSX 10.6.8

      From the start. I installed FM 12 Pro Adv using the upgrade package and license. I disabled IWP on my FM 10 install and enabled it on my FM 12 install. <- Have to do this as two FM installs will not both do IWP at the same time. I converted one of my DBs from FM 10 to FM 12 and there was no issues that I could tell. I then made sure that the DB was useable by everyone. I then navigated to the IP and port of the FM12 IWP and it shows the homepage but there is a message that there is no DBs to display. (See Screen)

      I read some things about making sure the file was useable by the Guest account and I followed their instructions and that still did not resolve my issue.

      Currently the DB is accessible by all users which means that anyone should be able to see it.

      Any help is appricated.

       

      Thanks,

      BITSSupport

      IWP_Home_Page_Screen_Shot.jpg

        • 1. Re: FM12 Pro Adv IWP Not Showing Databases
          davidanders

          Eliminate the database as the source of the problem.

          Create a new database from one of the starter solutions.  And test.

          It can also be a preference that needs deleting. This could be in the user or the system. (a Google did not provide much guidance)

          Create a NewUser (with admin rights) and logout and login as new user and test.

          NOTE: you probably have two of these - one in each FMPA install. (These would be system wide and not user specific)

          Not specific to your case, but...

          Note: If you are still receiving this error with FileMaker Pro 9.0v3 on Leopard your web.pref file may be corrupt. Delete this preference file before attempting to turn on IWP.   The web.prefs is found in the following location:

          /Applications/FileMaker Pro 9/Extensions/Web Support/web.prefs

          • 2. Re: FM12 Pro Adv IWP Not Showing Databases
            JoeCoon

            @davidanders,

            Thanks for your suggestions. I already tried making a new database with FM 12 and that still did not show in the IWP homepage. I also have tried creating a new user (with admin rights) and that also did not help.

            Seeing as I am using FM 12 and not FM 9 I am not sure why you suggested I do a fix for FM 9? I found and deleted the web.prefs for FM 12 and no luck.

            FM12 Pro Adv on Mac OSX 10.6.8. Snow Leopard.

            Any other suggestions?

            • 3. Re: FM12 Pro Adv IWP Not Showing Databases
              davidanders

              If you open a browser on the same computer,  127.0.01:yourportnumber  eg http://127.0.0.1:591
              this will be your computer talking to itself and looking for IWP.   worth a try

              The following thread may be helpful

              From   Having Problems with Instant Web Publishing

              If there were a port problem, it may very well be that you never get a response.  For example, if FileMaker Pro is not open, then you should get a "Failed to Connect" error message, which confirms what you are saying.  However, I wanted to eliminate any possibility of that happening and suggested using port 591 which is reserved for FileMaker Pro.

              On my machine, I have FileMaker Pro open without any files, and Instant Web Publishing is turned on.  On the second machine, I access the first machine using port 591, and I get the "Instant Web Publishing" web page with "No databases available".

              I then open a database file, go into "Sharing -> Instant Web Publishing", select the file under "Currently open files" and set access to "All users".  When I reset the browser on the second machine, my database now appears.

              If something was blocking Instant Web Publishing, then you wouldn't receive the Instant Web Publishing page.

              In my System Preferences -> Sharing, I only have File Sharing and Web Sharing checked.

              I have created a test file with all the correct settings that opens for me with Instant Web Publishing.  I have sent this file to our Technical Support contact person, and I'll have him email it to you to test.

              AT THE END
              1]  I finally figured out what my problem was. The change that triggered the problem was going from an ethernet hub to an ethernet switch. The problem was that I was using the null-modem cable used connect to hubs and using it to connect the DSL modem and the switch. I should have been using a standard cable. That must have confused it about where localhost was. I could see fmiwp looking for fmpro on localhost but not being able to find it when the DSL modem was connected.

              2] I had exactly the problem described above, and I fixed it by disconnecting from the wireless network and reconnecting. I did change the port to 8080 from 80, too.

              3]  I ran into the same problem and was going nuts trying to figure it out. so what i did was launched another database checked to see if i could access it and i could. so i relaunched my original database and the problem was gone. hope this helps. i think the problem comes from when someone is logged in and you close filemakerpro. when i repeat the steps of closing FM when a user is logged in i get the same issue. perhaps this a FM Pro issue and not a FM server issue.