AnsweredAssumed Answered

FMP12 upgrade, container fields and OLE

Question asked by NWbutcher on Aug 28, 2012
Latest reply on Aug 29, 2012 by philmodjunk

Title

FMP12 upgrade, container fields and OLE

Post

I'm really excited to see how FM is using the new enhanced container fields with external storage.  I got my new copy of FMP12 today and started to play, but ran into problems pretty quickly.  We use FM for an internal purchasing system, generating dozens of Purchase requests daily.  One of the most useful aspects is the ability to store PDF's of all of the associated paperwork (quotes, invoices...) in container fields (embedded).  But FM is quite inefficient when embedding PDF's.  Our database file sizes ballooned quickly to over 10 GB even though we only added 500 MB of PDF's.

I converted the file over to the .fmp12 format easy enough.  I ran into problems when I tried to convert the container fields over to external storage.  Of the approx 2400 records with embedded PDF's, only one successfully converted over to the new external container field.  The one that did, was the one record I created after I converted the orginal database over to the .fmp12 format.  Checking the transfer log, I get over 2400 lines of

.......  [Record ID 2407, field Attachments::Attachment] Skipped non-transferable data: OLE object

Will I not be able to take full advantage of the external storage/enhanced container fields, using my existing databases, which is the primary reason for wanting to do the upgrade in the first place?

These databases are about 7 years old,  currently running on FileMaker Server Advanced 11, hosted on Windows Server 2008 R2,  all clients who interact with the container fields are all Windows 7 FileMaker Pro 11 clients.  Even though I use FMSA, no aspect of these databases use IWP, XML, PHP or ODBC/JDBC.  I do not use an external connections to these databases, they only interact with FMP clients.

Another issue I found, is secondary, but really kinda reduces the "ease of use" factor for the new version of FileMaker.  I notice that any of the new records with container fields, when I drag the PDF into the container field, it no longer shows a thumbnail of the PDF, and more importantly, I can no longer just double click on the thumbnail (lack thereof) or file icon to open the PDF in Acrobat or Reader.  You can on any of the records that were existing previous to the conversion to .fmp12.  I know it the new fields can be accessed by 'exporting field contents' but when users are generating a dozen or so records a day, and accessing well over a hundred of these container fields a day, even the minor amount of time it add really starts to add up, not to mention all of the bogus copies of the files that get created because you have to 'download' a new copy each time you want to access it.

Thankfully I am working on copies of the databases, in a test server enviroment.

Are there workarounds to my issues, or should I hold off on upgrading my users and server?

Outcomes