6 Replies Latest reply on Sep 25, 2012 5:48 PM by CPSEN

    FMP5.5 won't import csv files

    CPSEN

      Title

      FMP5.5 won't import csv files

      Post

           Using FMP v.5.5 on a Mac, and I can't get it to recognize some .csv files for importing.  The problem files were exported from a v.5.5 file, updated in LibreOffice, saved as a .csv file when done.  When I go to import the resulting file, it shows up grayed-out as if it's not a csv (Import options set to select All File Types).  Oddly, I was able to get it to work once.  Note that when I have both open (FMP5.5 and LibreOffice) both seem to hang.  If I force-close LibreOffice, FMP will often free up.  Not sure that's relevant...

           I also can't import dirctly from a .csv that was created under Salesforce (salesforce.com) for the same reason, the Salesforce file can't be selected for import despite being a .csv.

           Anyone heard of this?

           Thanks a ton.  Carl

        • 1. Re: FMP5.5 won't import csv files
          philmodjunk

               What file extension do the files have? .csv? .txt? or ???

          • 2. Re: FMP5.5 won't import csv files
            CPSEN

                 .csv

            • 3. Re: FMP5.5 won't import csv files
              philmodjunk

                   Are you able to open these files in a text editor or word processor? a csv file is really a text file with commas separating the field data so they should open readily in with an application that works with text.

              • 4. Re: FMP5.5 won't import csv files
                CPSEN

                     Thanks, PhilModJunk.  Yes, the files will open in a text editor, or will open into a spreadsheet program depending on how I choose to open it.  

                • 5. Re: FMP5.5 won't import csv files
                  davidanders

                       TextWrangler by the makers of BBedit is free, and may be able to clean the files.

                  http://www.barebones.com/products/TextWrangler/

                  http://hints.macworld.com/article.php?story=20090905140006229
                       If you're going to be doing serious find and replacing, I would recommend TextWrangler. If you are willing to take an hour or two to learn how to do regular expression (grep) pattern matching, it will make your life a whole lot easier. See the TextWrangler help for a good guide.

                  • 6. Re: FMP5.5 won't import csv files
                    CPSEN

                         OK David, so are you saying the reason FMP5 won't read the file as importable could be b/c of some garbage in the file?  Is that b/c newer word processing software typically puts garbage into files?  CSV seems like such a simple and standard file type that it's hard to believe it could be trashed by any software (but I suppose I COULD believe it...).   I've had trouble opening an Excel file generated by Salesforce.com in Calc too, and I think it may have to do with some HTML encoding in the file that Calc doesn't like.

                         I'm very fluent with manipulating CSV style files in a spreadsheet like Excel or Calc (OpenOffice and LibreOffice versions of Excel), but most of my manipulation happens in FMP.  In my case I had to align key field data from a different database with my data in FMP.  I tried to simply do an update directly from what the other database sent as a .csv, but that didn't work b/c FMP wouldn't recognize that .csv file.   I then tried to take the .csv generated by FMP, add the key fields in Calc (usign a lookup), then saving as CSV and importing that into FMP.  No joy there either.

                         Finally, I've had luck with other csv files generated by Calc going into FMP, so I suppose there might be some junk, but I'm confused why FMP wouldn't even "see" my files with the .csv extension.

                         Thanks again.

                         Carl