AnsweredAssumed Answered

FMPA 10 and disk space: problems noted

Question asked by ralvy on Nov 4, 2009
Latest reply on Nov 4, 2009 by ralvy

Title

FMPA 10 and disk space: problems noted

Post

I noticed some strange things today. When I was in Layout Mode, and chose to move to a different layout via the Status Bar, I didn't see my entire list of possible layouts. The list ended without a bottom arrow. I tried this repeatedly. After closing FMP and restarting, and the reloading the solution, the layouts appeared properly on the dropdown menu.

 

Earlier the same day, I was examing a script I use to import data from one .fp7 file to another, importing table by table in that script. I noticed that the Target data file was displaying as "<unknown>". When I clicked on the Target dropdown field, only Related Tables displayed. This occurred repeatedly until I exited FMP and then started it again, and reloaded the solution. The second time showed the proper Target Table in the import dialog.

 

Recovery shows no problem with the solution files. Neither does FMDiff.

 

I also noticed that if I had the above solution loaded, and then opened Base Elements, FMP crashed.

 

Thinking there might be something wrong with FMP itself, I attempted a reinstall. I reinstalled FMPA 10.1 and then reinstalled the 10.3 update. The result was that the reinstall of the update removed the entire FMPA installation. So I had Windows uninstall FMP 10 (whatever it found, I guess, because there was no working installation I could find). And then I attempted to reinstall 10.1 again. This time I was greeted with a message about low disk space on the intended target drive. Providing more space on that drive solved this problem, and now I have 10.2 running fine.

 

So, upshot is that I think all the problems outlined in this post were related to low disk space. Perhaps this will help someone else who experiences what I experienced before finding out about the low disk space.

 

As a result, I have some questions:

 

1. Is there any reason to not trust the state of the solution I've been developing under low disk space, especially since the condition seemed to result in things like you saw in the first two paragraphs above? I have made sure that copies of the solution I'm working on is a copy that existed before the crash noted above.

 

2. When FMP crashes, does it produce an error log somewhere? The only error log I find is that produced by Windows XP's Dr Watson:

 

Application exception occurred:
        App: G:\FileMaker\FileMaker Pro 10 Advanced\FileMaker Pro Advanced.exe (pid=5300)
        When: 11/4/2009 @ 10:41:28.125
        Exception number: c0000005 (access violation)

 

3. Why doesn't FMP alert the user about low disk space?


Outcomes