3 Replies Latest reply on Nov 11, 2008 9:26 AM by TSGal

    FMPro Win sees Mac database but won't connect (coffee cup)

    jaydisc

      Title

      FMPro Win sees Mac database but won't connect (coffee cup)

      Post

      I have a Mac running FMPro 8.0v3 and a Windows user running 9.0v3. The Windows user is connecting to the Mac's network over a VPN and can see the Mac host using Favorite Hosts and choose the relevant database. When they click open, they get the coffee cup pointer for about 30 seconds and then it returns to being the arrow with no error message.

       

      Is there a log I can find more valuable debugging information?

       

      I have added the FileMaker Pro application as an Exception to the Windows Firewall, and from the Mac running TCP dump, I see the Windows computer initiate a connect starting with 1074 to the Mac on 5003. The Mac responds and after a few packets exchanged, the Windows computer goes to the next highest port, 1075, etc.

       

      The Windows machine has temporarily disabled virus protection to no avail, and from the Mac, I can port scan the windows PC and see all sorts of open ports including 5003.

       

      What could be the cause? Could this be a version mismatch issue? Most likely not as a Mac running 9.0v3 can still happily connect to the Mac running 8.0v3.

       

      Is there any log with more detailed debugging info on the Mac or PC?

       

      TIA. 

        • 1. Re: FMPro Win sees Mac database but won't connect (coffee cup)
          Vaughan
            

          Is the list of available hosted files being displayed?

           

          It could be related to the SSL problem...

           

           

          Read the FMI Tech Info article:

          Invalid SSL certificates created when FileMaker Pro is installed on or after Sept. 22, 2008
          • 2. Re: FMPro Win sees Mac database but won't connect (coffee cup)
            jaydisc
              

            Thanks for the reply.

             

            The list of available hosts won't be available because that isn't possible over a VPN, so I've used Favorite Hosts. When selecting that host, the available Database does show up, and there is a network traffic exchange that I can sniff, it just never succeeds and annoyingly, never reports an error.

             

            The SSL certificate issue is when connecting to a SERVER with SSL enabled. This is a peer to peer connection. Regardless, I tried the update and it made no difference. 

            • 3. Re: FMPro Win sees Mac database but won't connect (coffee cup)
              TSGal

              jaydisc:

               

              Thank you for your post.

               

              First of all, the mismatch in versions (8.0, 9.0) is not a problem.  Although we are all running 9.0v3 here, I sometimes do testing with 8.0 (and 7.0) to try different things out, and I'm able to see across a network and view files.

               

              I see that you are trying to log into the Mac from your Windows machine.  Have you tried the opposite route?  That is, have you tried accessing a hosted file on the Windows machine from the Mac machine?  Any problems?

               

              Are you able to bring down the firewall and test it out?

               

              The fact that you are able to see the file but not access it concerns me. 

               

              There are several unknowns, and I'd like to start from the basics and add things one at a time.  That will help me determine where the possible conflicts might occur.

               

              I'm sorry I don't have a definitive answer.

               

              TSGal

              FileMaker, Inc.