2 Replies Latest reply on Jun 19, 2013 9:08 AM by philmodjunk

    Forced Fields

    AlainaBudd

      Title

      Forced Fields

      Post

           Im using Filemaker Pro 8 and the database im using was originally set up that when you created a new record you were not able to click in the background area of the database without clicking some chosen fields. If we click in the back ground a message appears saying we must click it. How do we over come it. How do we change it so its not a forced field

            

           Alaina

        • 1. Re: Forced Fields
          JimMac

               I am guessing that you have a Validation Message on the Field.  If i am guessing right...

               With the FileMaker File open...

               Under the FILE menu ==> Define ==> Database  

               This brings up a window with 3 tabs at top.  TABLES  FIELDS   Relationships.

               Select FIELDS....

               This is a list of Field and perhaps they are named similar to the Field that is forcing you to Select.   

               Under the Column name Options / Comments

               Check for and a field that says  Required Value... 

               Select that field [hopefully is the one that is named like your forced field]  

               At the near bottom right of window is  a button named Options...  click on it... you get a new window

               Click on Validation... and Uncheck NOT EMPTY   then OK and OK on main window...

               Jim...

                

          • 2. Re: Forced Fields
            philmodjunk

                 It's also possible, though I think Jim's guess is the more likely one, that there is a large button covering the layout background that performs a script when clicked. You might need to check for the presence of that button and remove it from the layout or use Ungroup to remove its button properties.