2 Replies Latest reply on Aug 31, 2013 11:37 AM by JohnMasters

    FTS4_03 Example 3.6.3

    JohnMasters

      Title

      FTS4_03 Example 3.6.3

      Post

           I am new to Filemaker and working my way through the tutorials but have come to a halt on the above example. Up to this point all was well but I cannot seem to get the "Allow creation of records in this table via this relationship" to work. If I try to add some data to the portal I get the error message:

           This action cannot be performed because this field is not modifiable.

           I also get this message if I use the solution file.

           Not sure what is wrong but any help would be appreciated.

           John

            

        • 1. Re: FTS4_03 Example 3.6.3
          philmodjunk
               

                    I also get this message if I use the solution file.

               Do you get that exact message with the solution file or does the message tell you that the FILE is not modifiable? If you see a message that the file is not modifiable use a copy copied from the supplied Disc and make sure that it's properties are not set to read only.

               If you are trying to create a new related record by entering data into a field in a portal and you get the field is not modifiable error message either the field you are attempting to edit is a calculation or a field for which modification has been prohibited in field options OR a match field defined for this relationship in the portal's table is not permitting modification for the same reasons. When you create a new record in a related table enabled by the "allow creation..." feature, FileMaker copies the value of the match field(s) in the layout's table into the match field(s) of the new record of the portal's table. If the portal's match fields prohibit modification, however, that prevents the fields from getting the copied value and you get this error message.

          • 2. Re: FTS4_03 Example 3.6.3
            JohnMasters

                 Doh! So busy concentrating on the details I missed the obvious. 

                 The tutorial said to create a portal with the fields xxxID etc. Obviously I cannot change or create a new index but because this was the first field in the example that is exactly what I tried to do. Creating a new record by entering the info into the first editable field worked fine.

                 Sorry for the confusion.