AnsweredAssumed Answered

Global field rejecting data in IWP

Question asked by KateBirch on Jan 31, 2013
Latest reply on Jan 31, 2013 by schamblee

Title

Global field rejecting data in IWP

Post

     Hi all,

     I'm having an issue with IWP.

     I have a global field at the top of a most layouts to "find" records without using the find button on the toolbar. The idea is that you enter a unique identifier for the record (URN) into a global field, and then press a button on the layout, which runs a script to find the record.

     However, on one particular layout, when I enter a number into this global field, the script doesn't work as expected. On investigation I've found that it is because this global field will not retain the data that I enter into it. Even if I just enter a number and press "commit" the field reverts to what it was before I changed the value. 

     I've tried removing the global field from the layout and starting again, I've tried copying it across from the layout that does work, I've tried deleting the offending layout and recreated (by copying in the "find" section from somewhere that works, and the rest of the layout from the one that was deleted). 

     What is really concerning me is that if I delete the global field, set up a new one, change all the scripts, it works the first few times, and then stops working, back to the problem that I have described above. Its beginning to feel like a corruption (the first I will have encountered working with FM, but I've worked with Access for years, so familar with the experience!) 

     This is a problem only in the IWP version. The client version works perfecty every time. 

     Any help or ideas would be appreciated. 

      

      

     Extra info

     DB is hosted on FM server adv 12, the recent update has been done. 

     I'm using FM Pro Adv 12. 

     The IWP behaviour that I have described occurs both in safari and IE. 

      

      

      

      

       

      

      

Outcomes