3 Replies Latest reply on Oct 8, 2013 1:34 PM by philmodjunk

    Go to related Record and Security issues

    TeresaKenyon

      Title

      Go to related Record and Security issues

      Post

           I have a script that I am using that when triggered should copy information into fields in 2 additional records related to the First record.

           The problem I am having is that under my Admin acct the script runs perfectly. However, under the more restricted data entry account the script step "Go to related records. Show only related records- Match current found set" only finds the first record out of the three.

           When I run the same script step under my admin account it works pefectly and sets the fields accross all three related records in the found set instead of just the first. I selected run with full access privileges which yielded the same results.

           Does anyone have any insight? I've also gone back and looked at the security settings. The user does have access to the layout that contains the list of records that I'm having them edit.

            

        • 1. Re: Go to related Record and Security issues
          philmodjunk

               But do they have access to the records involved? It's possible to set up security settings that control access to these records on a record by record basis so perhaps the settings in that privilege set permit access to some records but not others.

               Try doing a show all records while on this layout and the file is open under the restricted level password and see if all records may be viewed or not.

          • 2. Re: Go to related Record and Security issues
            TeresaKenyon

                 Hi, Thanks for helping! Yes, they do have the ability to view all the records in this layout. I just tested it. But the script still is only editing in the first record.

                 When I run script debugger in that acct it doesn't "match all related records" as it does in the admin account. It only selects the current record... So when I have the next step "Go to record (next)" I get the 101 error message.

                 Again, when I run the same script under my account it runs perfectly. Finds all 3 related recrods and sets the fields appropriately.

            • 3. Re: Go to related Record and Security issues
              philmodjunk

                   You'll need to describe this in more detail. I'd like to see the actual relationship you've defined and the actual script used before making any guesses as to why this is happening.

                   To post a script to the forum:

                     
              1.           You can upload a screen shot of your script by using the Upload an Image controls located just below Post A Answer.
              2.      
              3.           You can print a script to a PDF, open the PDF and then select and copy the script as text from the opened PDF to your clipboard for pasting here. (with this approach, you can get multiple script steps on the same line, please edit the pasted text by inserting some returns to separate those steps.)
              4.      
              5.           If You have FileMaker Advanced, you can generate a database design report and copy the script as text from there.
              6.      
              7.           If you paste a text form of the script, you can use the Script Pretty box in the Known Bugs List database to paste a version that is single spaced and indented for a more professional and easier to read format.