5 Replies Latest reply on May 4, 2012 9:36 AM by RobertMoya

    Hide fields in different Views

    RobertMoya

      Title

      Hide fields in different Views

      Post

      I have FM12 and i have a field called "Calculated Length" which is a summary field that calculates the lengths of our cables. In "Form" view i have a layout made for printing but i dont want the "Calculated Length" field to be on there, once i made the field in Table View, it automatically put it in Form View also, so i deleted it, then realized it also deleted it from the Table View.

      Is there a way to have it only be in the Table View and not in Form View?

      Thanks

        • 1. Re: Hide fields in different Views
          DavidM

          Try this: Go in to Layout, select the field that you do not want ot be printed, go to Inspector, and under Sliding and Visibility, check under Object visibiity, the Hide when printing box

          • 2. Re: Hide fields in different Views
            philmodjunk

            You can also remove the field from the layout, but use the Modify button to add it to the table view. This isn't always the best option as specifying certain formatting options for such a field require adding it to the layout so that you can specify those options while in layout mode.

            Ultimately, you may find it useful to create a second layout so that you have one for your table view and one for your form view.

            • 3. Re: Hide fields in different Views
              RobertMoya

              I did that, and it hid it, but then i went back to my Table View and it wasnt there, i clicked "Modify" to see if it was just hidden and it wasnt even in the of fields.

              • 4. Re: Hide fields in different Views
                philmodjunk

                Ultimately, you may find it useful to create a second layout so that you have one for your table view and one for your form view.

                I'm not getting the same results here.

                I just tested to make sure that v12 isn't throwing any suprises at me here...
                I clicked the table view button.
                I clicked the Modify button.
                I clicked the plus sign button needed to add a field.
                I added it.
                I can now see this added field in table view.
                I clicked the Form view button and the added field is no longer visible.
                I clicked the Table View button and it re-appeared.

                • 5. Re: Hide fields in different Views
                  RobertMoya

                  Got it to work, i deleted a field from my Form View and saw that it was removed from the Tbale View also, then like you said, I hit modify then the "+" and added it on the Table View and checked back at the Form View and it wasnt there :)

                  Thanks again