1 Reply Latest reply on Jun 25, 2014 3:18 PM by philmodjunk

    Hide Layouts for certain users but allow changes to the table

    JosephFalduti

      Title

      Hide Layouts for certain users but allow changes to the table

      Post

           I have numerous layouts tied to tables that are embedded in one main layout.  I have a large number of users who should not have access to the information in some of the tables and who I do not want going into different layouts from the menu.  However, I want them to have access to add and modify records from the layout, as they occur in portals throughout the main layout.  Therefore, I wish to simply hide all but one layout from the menu.

           I have gone to the security settings and tried to set custom settings for layouts.  However, if I set a layout to "No Access" then there is automatically "No Access" to add records, even when viewed through a portal.  (We have portals set up where one can click a button to create a new portal record.)  I can simply manage the layouts and hide all but one from view, but then administrators would not be able to see those layouts.

           Is there a way to hide layouts for certain users (i.e. not admin users) but still enable those tables to have records created and modified?

        • 1. Re: Hide Layouts for certain users but allow changes to the table
          philmodjunk

               Setting a layout to "no access" should not deny access to the table on which it is based as long as you access that data from the context of another layout to which the user does have access. It may be that the option chosen in available menu commands drop down was too limited to allow adding records.

               But you can also remove all layouts to which you want to limit access from the layout drop down by clearing the "include in layout menu" check box found in Layout Setup and also in Manage | layouts. You then use buttons with scripts (and possibly a drop down list of your own design) to control access to different layouts in your database.