7 Replies Latest reply on Nov 20, 2013 9:56 AM by philmodjunk

    How to disable Edit layout Button

    SamThomas

      Title

      How to disable Edit layout Button

      Post

           I want to disable  edit layout so that user cant edit it.But they can manage scripts.

        • 1. Re: How to disable Edit layout Button
          philmodjunk

               It seems odd that you want them to be able to create scripts and not modify layouts. What user scenario will require that?

               Just opening Manage | Security and looking at the settings you can choose for a privilege set suggests that you can set up an account with a privilege set that allows modifying scripts but denies the option to modify layouts... (But make sure you select the least restrictive option in "available menu commands".

          • 2. Re: How to disable Edit layout Button
            SamThomas

                 Thanks for reply I try this In Manage->security->Privilege->script->All Modifiable and also enable create new script but still I can create new script

            • 3. Re: How to disable Edit layout Button
              philmodjunk
                   

                        I try this In Manage->security->Privilege->script->All Modifiable and also enable create new script but still I can create new script

                   and that's what should happen or do you mean "I still Can't create a new script..."

                   If so, what option did you select in Available Menu Commands?

              • 4. Re: How to disable Edit layout Button
                SamThomas

                     I set it all 

                • 5. Re: How to disable Edit layout Button
                  philmodjunk

                       It works for me when I test in a small test file. Here's what I did:

                       I opened Manage | Security and created a new account with a new privilege set. I selected the options shown in the uploaded screen shot.

                       When I log in using the Limited access account, I can open Manage Scripts and create/delete scripts but the Edit Layout button is disabled.

                       Here's the file: https://dl.dropboxusercontent.com/u/78737945/LimitedAccessTest.fmp12

                       Use admin with no password to open the file in Full Access and use an account name of Limited and no password to open the file in limited access.

                  • 6. Re: How to disable Edit layout Button
                    SamThomas

                         Ok I will check it out .In file->file option->Login using ..What is this If I create account name then agn need to specified it in that ???

                    • 7. Re: How to disable Edit layout Button
                      philmodjunk

                           The options are specified in the Privilege Set. You can create as many accounts as you need and can assign the same privilege set to each.

                           But I'm not sure that I understood your question:

                           

                                Ok I will check it out .In file->file option->Login using ..What is this If I create account name then agn need to specified it in that ???

                           I cleared the check box in File Options to keep the file from automatically opening with the Admin and no password default which will still open this particular file in full access without asking for an account name and password. Any time the check box is cleared or there is no account name/password specified in Manage Security to match, FileMaker pops up the Log In dialog.