6 Replies Latest reply on May 6, 2011 9:05 AM by philmodjunk

    How to set cursor starting position



      How to set cursor starting position


      How do I set the starting position for the cursor in a multiline text area. After creating the text area, the cursor seems to start at the middle of the form field, see screen shot. screenshot


        • 1. Re: How to set cursor starting position

          It looks like this is a single text field and is NULL (empty).  Is that correct?  I don't believe it is because it would not start in the middle unless there are carriage returns or spaces which move it down.  Since the field should be empty, I would suggest removing the garbage first and then naturally you would start at the top.

          Without knowing your exact situation, you can place the cursor above all the garbage by attaching a script trigger to the field which would be based upon OnObjectEnter.  Script would be simple:  Set Selection [ yourTextField ; Start Position: 0 ; End Position: 0 ]

          But I would try to discover why the field has spaces/carriage returns and attempt to clean this up at same time.

          • 2. Re: How to set cursor starting position

            Thanks for the response. The field is a text field, and I checked the option to allow multiple line. As far as there being carriage returns, there shouldn't be any, and as fas as I am concerned, there aren't any. I am thinking it maybe the way I am creating the object. I place the text field object on to the form, then I check the box to allow multiple lines, then I drag the top, botton, and side object handles until I have the size of the field that I want. I then preview the form, and the cursor is down at the middle of the field. Could that be the reason for cursor being down there, the way I size the field?

            • 3. Re: How to set cursor starting position

              "I checked the option to allow multiple line"

              I'm not sure what option you clicked there, as you can enter multiple lines of text into any text field. I do think I know what the issue is however.

              1. Enter layout mode
              2. Click the field
              3. Check the vertical alignment option in the paragraph section of the Inspector's appearance tab. I think you have selected centered vertical alignment. That's the sixth button from the left in the alignment section. Click the button immediately to the left of this one to specify top aligned text and your cursor will now appear at the top of the field.
              • 4. Re: How to set cursor starting position

                I guess this is kind of the same issue, but I am also having trouble getting the words type to be on the line. Instead they are floating above the line, rather than on it.


                • 5. Re: How to set cursor starting position

                  OH my god, I am so embarassed. I am in the wrong forum, lol. I should be in the Adobe Livecycle forum. When PhilModJunk mentioned about layout mode, that is when it hit me that I am not using filemaker. I apologize for the trouble.

                  • 6. Re: How to set cursor starting position

                    As far as I can tell from your screen shot, the line you are referring to is the bottom boundary of the field. Since you can set any field height you want and you can vertically align the text with top, center or bottom, you have a few different options you can play with here:

                    1) Resize the field to make it shorter. You can "fine tune" the size of a field by selecting it, then entering a new height in the height box on the inspector's position tab. If you first click on the units to the right of these boxes until you see Pixels, you can easily "tweak" the height of your field by very small increments.

                    2) Change the vertical alignment of the field to align the text to the bottom of the field instead of the middle or the top.

                    3) Make the text a larger size to more completely fill the field.