1 Reply Latest reply on Oct 21, 2010 11:42 AM by philmodjunk

    I need to edit and add into a field that is not allowing me access, being "non-modifiable"..

    MariaKovacs

      Title

      I need to edit and add into a field that is not allowing me access, being "non-modifiable"..

      Post

      I need to update key names (Example: "inventor names") on FileMakerPro 10 and it's "non-modifiable".  (The person who used to work on this program left the company and nobody here knows how to use it. )

      Problem: I need to edit and add into a field that is not allowing me access, being "non-modifiable"..

      Question:  How do I make this field modifiable?

      1.   is it because the names (inventor names) are being pulled from another source; perhaps, an "employee list" ? Is that why I cannot fill out the fields with the Last name, First name, etc.?

      2. where do I look for this "source" in order to add new employee's (inventors). (I looked on all the other drives I have on my system, and didn't find any kind of employee or name list.)

      Thanks,

      MK

        • 1. Re: I need to edit and add into a field that is not allowing me access, being "non-modifiable"..
          philmodjunk

          "nobody here knows how to use it"
          I strongly suggest you either prepare to hire a consultant or invest the needed time to learn how Filemaker databases work. There are books and tutorials available on the subject.

          There are several possibilities:

          1) the field is a calculation field that computes a value. This can't be modified unless you change its field definition. It might be possible to change such a field to a data (number, date, text) field with an auto-entered calculation, though this might create problems for you I can't predict without knowing more about the database and this field definition. If it is a calculation, you may also be able to find a field that the calculation references and then edit the data in that field to get new data to appear in the field.

          2) There's a field setting called "Prohibit modification of value during data entry". If this is the cause, you are in luck as you can just turn this field option off to permit modification.

          In either case, enter layout mode and examine the field on the layout. Double click the field to pull up the Field/Control dialog so you can see the name of this field highlighted and the name of the table it comes from in the drop down at the top of this dialog.

          Now open Manage | Database | Fields and find this field's definition. If you can't find the table that was listed in the drop down, you may have to click on the tables tab and search the last "occurrences in graph" column to find it. If you find it there, use the table name in this same row listed in the first column when switching back to the Fields tab and looking for it.

          If your field is a calculation, it'll be shown as having the type calculation. If not, it should show a field type of Text. Double click it and check the bottom of the Auto-Enter tab to see if the "prohibit modification" check box is selected. Clear this check box and you are in business.