2 Replies Latest reply on Dec 5, 2013 2:43 PM by NathanJones

    Import Records issue

    NathanJones

      Title

      Import Records issue

      Post

           We are using FileMaker 12.0v4.Working in pinksheet.  When we go to file > Import > file, then select a file to import, it brings up the Import Field mapping dialog box. This is where the issue is. It has source fields on the left, and target fields on the right. The issue is that it is dumping as much data as possible on one line, and then it breaks down to the next line, and so on. For instance, for instance the first 3 targets fields on the right are ( Last name, Social security number, and Date of Birth ). When you look at the source fields on the left, I should just see the last name. Instead it has the next 7 target fields worth of data all on ONE line in the source fields. It fills that line with as much data as it can and then breaks down to the following line. So then the next target field should be SSN, and it starts with the address ( which is about 7 target fields down ), and then it has about 7 fields worth of data, before it breaks and goes on down to the next source field. So in the end - there is only about 10 target fields that will get any data. The rest are blank all the way down the page.

           I will attach an image. As you can see, multiple fields are stacked on top of each other. The fields aren't lining up.

           Has anyone seen this?

      importissue.png

        • 1. Re: Import Records issue
          philmodjunk

               From what file type are you importing? IS this a tab, csv, excel or other file type?

               It appears the problem is with the format of that file and the specific file type that you are selecting for your import. Example: if you selected Tab as the file type for your import, there needs to be a tab character between each column of data to be imported and a return between each record. You'd get what you describe here if the data that should import into separate fields is not separated by tab characters. Missing commas for a csv import would produce the same result.

               And you can drag the fields on the right up and down to align them with different columns of import data on the left in order to get the correct column of data into the correct field--but only if FileMaker can successfully parse the data to import into the correct columns and this will depend on the format of the data in your file and the options you select during import.

          • 2. Re: Import Records issue
            NathanJones

                 I appreciate your help, I think that really helped and I will look into this and come back here to let you know.