AnsweredAssumed Answered

Import->XML Multiple Related Tables

Question asked by spesic on Jun 15, 2010
Latest reply on Jun 29, 2010 by comment_1

Title

Import->XML Multiple Related Tables

Post

FileMaker Ver.: 9

OS: Win 7 x32

 

Hi all,

 

I'm a web developer mostly dealing with PHP/SQL and I'm fairly new to FileMaker database.

I was hired by a contractor who wanted to develop a web application (registration form for their clients).

It's pretty much a standard reg. page with bio/demographics/etc.

 

Previously they had a fillable PDF which their clients would fill and send back to the contractor, and then they would have someone manually enter this data into FileMaker Pro.

Now this is all done online and stored within SQL database.

 

My contractor would like, if possible, to be able to export data from SQL into FileMaker database on a monthly basis. This would be convenient as they can produce montly/yearly reports and other neat things that FileMaker does rather than having to pay me more money to develop this in PHP.

 

I did this for one of my previous clients so I thought this shouldn't be a problem. The earlier project I worked on had only one table and my XML export worked like a charm.

However this particular database has multiple relational tables that looks something like this:

 

 

       MAIN  ----- Other Stuff
     /     |
    /      |
   Bio.   Demographics

 

 

It's much more complex than that, but I'm going to leave it with 3 relational tables for the simplicity.

So I first did the export records to XML to se the format and I noticed that the metadata from relational tables looks something like this: tablename::fieldname (e.g. education::university_name) so I figured that's all I had to do when I generate XML from SQL database.

 

When I try to import this XML into FileMaker Pro database the fields from the MAIN table are automatically recognized and paired up with the ones from XML file. However all other fields from relational tables are not recognized and cannot be paired up with ther fields in FileMaker Pro. It is as if I can import into only one table at the time.

 

Am I missing something here or is there no way to make this happen?

Outcomes