7 Replies Latest reply on Sep 21, 2012 3:16 AM by JimMac

    Imported text

    GaryVogt

      Title

      Imported text

      Post

           I imported text off the internet that was in Courier font.  I have tried many different ways of moving it around but I can't seem to change the font into something I can use.  

           Any ideas?  

           iMac OSX 10.6.8
           Filemaker 12.0v2

        • 1. Re: Imported text
          davidanders

               http://help.filemaker.com/app/answers/detail/a_id/5674/~/removing-text-formatting-from-a-field-in-filemaker-pro

          How do I remove text formatting from a field?
          Answer ID: 5674Last Updated: Dec 03, 2011 08:50 PM PST

               Sometimes text within a field has had formatting applied to it (color, bold, font, size, etc.). Formatting applied to text within a field will override field formatting applied to the field as a whole when in layout mode. It's possible to create conflicting formats by creating one format for a field object in Layout mode, and a contrasting format for field data in Browse mode. Here is how FileMaker Pro resolves text formatting conflicts:

                 
          •           
                           When you format a field in Layout mode, the formatting affects only the appearance of that particular occurrence of the field object.
                 
          •      
          •           
                           When you format field data in Browse mode, this formatting is stored with the data, and you see it in any layout that displays that field. Field data that is formatted in Browse mode takes precedence over data formatting in Layout mode. For example, if you format field text as Bold in Browse mode, then switch to Layout mode and format the same field as Plain Text, the text will continue to display as bold.
                 

               It is often desirable to remove this formatting in order to make the text in the field comply with the field's formatting.
               The easiest way to achieve this is to use the TextFormatRemove function.
               This removes all text formatting from text in a single action. All fonts, styles, font sizes, and font colors are removed from the specified text.
               The following methods show how to implement these functions:

          Method 1: Prevent text from being formatted during data entry.
               A field can be defined to make sure data is entered in a specific format, or within a certain range. To save time and ensure accuracy, you can set FileMaker Pro to automatically enter unformatted data in a text, number, date, time, and container fields. For example, field.
               To set options for automatic data entry:

                 
          1.           
                           With the database open, choose File menu > Define > Database.
                 
          2.      
          3.           
                           In the Define Database dialog box, click the Fields tab.
                 
          4.      
          5.           
                           If your database contains more than one table, select the appropriate table from the Table list.
                 
          6.      
          7.           
                           Select your text field from the list of existing fields, or define a new one, for example fieldA.
                 
          8.      
          9.           
                           Click Options (or double-click the field name). 
                 
          10.      
          11.           
                           In the Options for Field dialog box, click the Auto-Enter tab and select the Calculated Value (or click Specify), then enter the following calculation.

                           TextFormatRemove(fieldA)
                            
                 
          12.      
          13.           
                           To make an auto-enter calculation self-modifying, leave the Do not replace existing value for field (if any) option unchecked.
                 

               Since Auto-enter calculations can be self-referencing, this will ensure that any data that has been entered will be stripped of any text formatting.

          Method 2: Remove existing text formatting using the replace command
               You can replace the contents of a field in all records or in a found set with a calculation that also uses the TextFormatRemove function.
          Important:  This process overwrites a field in every record (or every record in the found set) with a new value. You can't undo replacing field values. Before you begin, consider making a backup copy of the file. 
                
                To replace field values in every record in the found set:

                 
          1.           
                           If necessary, find, omit, or sort the records in the database file.
                 
          2.      
          3.           
                           In Browse mode, in the current record, select the contents of the field you want to replace, for example fieldA.
                 
          4.      
          5.           
                           Choose Records menu > Replace Field Contents.
                 
          6.      
          7.           
                           In the Replace Field Contents dialog box, select Replace with calculated result, then click Specify.
                 
          8.      
          9.           
                           In the Specify Calculation dialog box, enter the following calculation:

                           TextFormatRemove(fieldA)
                            
                 
          10.      
          11.           
                           Click OK.
                 

               This method is good for changing one field at a time on a given set of records or all records.
               The following are alternative methods that will also achieve this:

          Method 3:  Manually reformat the text
               To eliminate formatting applied in Browse mode, manually reformat the text in Browse mode.Sometimes when there are a small number of fields and records involved, it is simpler to just select the text in question while in Browse mode and change it to the appropriate font, font size, and font style using the selections available from the Format menu (you can turn off multiple styles by using the plain text option). Make sure you select all the text in the entire field or else other layouts may not conform to the changes.

          Method 4: Export and Import text
               To eliminate formatting applied in Browse mode, export data as text and re-import the data.
               This method is useful when multiple fields across multiple records are affected. The process of exporting and importing information as tab or comma separated text will strip a field's contents of its formatting. In order to use this method, find the affected records and export them to a tab separated text file. Then, import those records using the setting 'Replace data in current found set.

          Important: Do not change your found set after exporting. Always, backup your database before executing a change like this, in case you make a mistake.

                

          • 2. Re: Imported text
            JimMac

                 I am Mac 10.6.8  fmp 12.

                 If  you use Cut from data source /Paste into a FMP Text Field, I can select all after the FMP record is committed. and change to whatever Font i want.

                 How did you import the text into FMP text field?

                 Jim...

            • 3. Re: Imported text
              GaryVogt

                   Thanks.  I never noticed that command before to remove formating.  It works.  Thanks again.

              • 4. Re: Imported text
                GaryVogt

                     I was duing copy-paste to get info into a file.  I realize I can reselect it and change it after it's there, it's just a waste of time if you as me.  

                     Personally, I think any text copied to a field should ALWAYS take on the properties of that field unless told otherwise.

                      

                     THe textforgetformat was a big help.

                      

                     Thanks everyone.

                • 5. Re: Imported text
                  Sorbsbuster

                  "Personally, I think any text copied to a field should ALWAYS take on the properties of that field unless told otherwise."

                       The properties of the field may be 'Helvetica, 10pt, plain'.  So you copy 2,000 characters of a really cleverly-formatted mix of typefaces, styles, and fonts, into a field, and it all goes vanilla.  How would you set that back to the lovely rich settings you copied?

                       Conversely: you copy the rainbow-effect ,trip-induced nightmare that is half the sites on the web, and in one command you make them presentable.  (And if you want to paste the text as unformatted from the get-go, a right-click achieves that in one go.)

                  • 6. Re: Imported text
                    GaryVogt

                         Sorbuster: Thanks for the comments.  You know, in 28 years of using FileMaker, I have never once had a situation where I had a lot of mixed text that needed to be maintained while creating text computations.

                         I still maintain the text should stay as formatted with respect to the field, not with respect to the source of the text.  If someone wants to maintain formatting, there ahould be a function to 'keep formating.'  Not  the other way around.

                         FileMaker user since 1986 on one of the original Macs.

                    • 7. Re: Imported text
                      JimMac

                           @Gary

                           Let me guess.... hmmmmm FM 2.5?  Me too on Mac + FM.  I agree with you Garyyes.  Many applications that manage text have this option.  My font variations seem less and less within a working data base.  Perhaps outputs and reports are more appropriate,

                           Jim...