7 Replies Latest reply on Sep 9, 2013 1:00 PM by philmodjunk






           I am importing from Excel and in the import the database imports ALL the rows in excel INCLUDING the empty ones. 

           Not sure if I am doing something wrong or...

           Any suggestions appreciated.

           Thanks for reading and any help.



        • 1. Re: importing

               Are these empty rows at the bottom of the spreadsheet or do you have empty rows between blocks of data?

               Are the cells in these empty rows truly empty or might their be some invisible data (such as a space character) in one of the cells?

               Are you importing the entire worksheet or specifying a range?

          • 2. Re: importing

                 They are after the rows that are imported. 

                 I don't know how to import just certain rows.  That is probably the problem, I thought the computer would figure out how to import just the rows that had data in them.

                 Thanks for answr. 



            • 3. Re: importing

                   That's what happens when I import records from an Excel file. If I have 5 rows in the workbook with data, I get 5 records imported.

                   That's why I am asking for more information about your excel file and how you went about importing this data.

              • 4. Re: importing

                     I am not sure what was below, if anything, but I went in and highlighted and deleted all the rows below and then the columns to the right and reimported and ended up with a clean import so I guess that is probably what happened.  It hasn't happened before and this one happened twice so there must have been something in the very bottom rows. 

                     Thanks for your answer, that seemed to work. 

                     But in the comment, a point came up:: can you tell the progam to just import so many rows and not all? 


                • 5. Re: importing

                       If you define a "range" in your file, you can specify that range during import.

                       Otherwise, you'd need to import all the records and then delete the ones that you did not want to import.

                  • 6. Re: importing

                         I have been hired to transfer 5000 records from a lotus database into the filemaker database.  They would like me to do this one record at a time.  I see that others are using excel to import.  I can do the same?  How do I set up the excel cells so they will make the filemaker cells?


                    • 7. Re: importing

                           FileMaker can import data from a number of file formats including Excel, Tab, Csv, and Xml. Excel may or may not be the best file format for importing.

                           When using Import record records with any of these file types, a field mapping dialog box will open where you can match the fields of an existing table to the different columns of the file of data being imported. Each row of data will make a different record in the table of imported data. If doing this manually, you should first go to a layout that is based on the table that will receive the imported data.

                           You can also use the "new table" option when selecting a target table and then FIleMaker will create the table as part of the import. IF there are columns in the first row, you also get an option to use that text to name the FileMaker fields so that they have matching names.

                           And you can also drag and drop an Excel file directly on the FileMaker Application Icon and get a brand new file with a new table that contains all the data from the file that you dropped on the application.


                                They would like me to do this one record at a time.

                           For FIVE THOUSAND RECORDS? Surely you mean that the table in in FileMaker must also have 5,000 records when the import is finished but that you can still import them all in one batch import? Otherwise, the "one at a time" aspect will slow your data entry down and this will take a huge amount of time to do so.