6 Replies Latest reply on Sep 8, 2011 3:37 PM by kj121

    Importing fixed width file problem

    kj121

      Title

      Importing fixed width file problem

      Post

      Hello,

      I am importing a fixed width file into one field ('big field') and then defing each field as an auto calc, for example, Field A (middle, 20, 30). (as described here: http://filemakertoday.com/com/showthread.php/15658-Importing-a-fixed-width-document )

      The import results in 65 records complete records but 46 records have incomplete data. Many fields are empty. The data is there in the original file. I just do not see what is wrong and have not been able to solve this. The auto calc is not the problem. The data is not there in 'big field'.  

      Any ideas? 

      thank you

        • 1. Re: Importing fixed width file problem
          philmodjunk

          Not without being able to see the data or to inspect a copy of the actual file.

          • 2. Re: Importing fixed width file problem
            kj121

            The problem is with the data. When the import hits commas the data ends for that record. How can I prevent that? I just want one fixed width record in 'Big Field', commas and all are fine.

            • 3. Re: Importing fixed width file problem
              philmodjunk

              Sounds like you've specified a csv file type for the import. Try using the tab file type instead.

              • 4. Re: Importing fixed width file problem
                kj121

                Oh, no, it is not cvs type at all. There are no delimters. There is no way to open the file using excel except to tell excel the start and end of every single field in a 600 character record. That is why I have created this filemaker solution. The commas are often in complicated addresses and often in error, but still, that is the data and I need the entire record.

                Users will be importing these files all year long. No one can manually edit these files. 

                thanks.

                 

                 

                • 5. Re: Importing fixed width file problem
                  philmodjunk

                  Yes, but what file format did you specify when importing into Filemaker?

                  That's what I am referring to. It sounds like you specified a csv file type at that point or FielMaker would not be interpretting a comma as the end of the field. If you use Tab as your file type option, commas will not be recognized as field delimitters, tabs will be.

                  • 6. Re: Importing fixed width file problem
                    kj121

                    Thanks for trying to help so quickly and so late.

                    There is not an option to say it is a cvs file. ? Wether it is the script step or file/import then select the file the result is the same. I see where I can choose a character set. Tried different character sets, no difference. blah, blah blah..... :)

                    Okay, so I did what you told me. the files are not named with a .tab. I always had to say show me 'all files'. Then I select the file to import. Renamed file to .tab, then at: show 'tab separated text files' I select the file. Presto! I have the data. 

                    Users can rename files with a .tab and I can give them a message to remind them. 

                    What a pill this was.

                    It is not easy to help people when you are not looking at the same things. Thank you very much Phil. Great.