4 Replies Latest reply on Mar 31, 2009 2:34 PM by philmodjunk

    Importing records - data doesn't transfer

    Terri

      Title

      Importing records - data doesn't transfer

      Post

      Hi, I am importing records from one database to another. I have followed all the import steps correctly, and the majority of the information did move. However, many data fields now have a ? rather than the data (specifcally date fields. The format appears to be exactly the same. Does anyone know why this is happening?

       

       

        • 1. Re: Importing records - data doesn't transfer
          marcusedward
            

          You may have issues if you enable the checkbox for auto entering during your import.  If for example a date field is an auto calculated result with the option checked it would try to calculate the result rather than import it.  I often find it is easier to turn off the auto enter function on import then go back to the imported data and use the "replace with" command to deal with the auto entry stuff (like if you have an auto generated serial number for example).  

           

          Data validations may also cause errors (depending on the settings).

           

          and lastly you should verify that the field types that your importing from match the receiving field type (text to text, date to date, etc.)

           

          Hope this helps.

           

          Marcus 

           

           

          • 2. Re: Importing records - data doesn't transfer
            philmodjunk
              

            "I have followed all the import steps correctly, and the majority of the information did move. "

             

            Just to rule out the obvious, what field matching option did you use. Do the fields in both source and matching field have the same name? If so, did you choose the matching names option?

            • 3. Re: Importing records - data doesn't transfer
              Terri
                

              I just did the import again and I was very careful to check all the things you mentioned. The type of field is the same on both files, the format of the field is the same on both files. Also, the field names are the same so I did the matching name option. It looks like the problem may have come when I exported and I chose apply current layouts format to exported file. I am not quite sure why that is a problem when the format is exactly the same, but when I chose NOT to do that, the information transferred successfully.

               

              Thanks for the help.

              • 4. Re: Importing records - data doesn't transfer
                philmodjunk
                   Aha, I think I see the problem. Click on your ? date field while in layout mode and check the date format settings. Dates can display in widely different formats and take up a great deal of more or less horizontal space depending on these settings. A ? can just mean that the field is not wide enough to correctly display the date. If that's the case, just make your fields a bit wider and you should be good to go.