1 Reply Latest reply on Apr 17, 2010 7:39 AM by Radcon

    Indexing - Relationship snafu

    Radcon

      Title

      Indexing - Relationship snafu

      Post

      I think I messed up.

      I do have back-ups, but I prefer to go forward if you can direct me.

      I had some relationships that seemed to work OK, but I couldn't leave well enough alone.  I deleted the links and moved the tables around on the graph to change the order of the relationships and then re- linked the tables. 

      The "Items" table has a field named _pItem_ID.  "The Locations"  table has a field named _pLocation_ID.   There is a third table between these two tables.  I created another table occurrence to directly re-link the Items table and the Locations table. Create records is allowed in both tables.

      When the records of either table are viewed in table view, I can see the ID numbers for its respective ID field, but not for the related ID field.  I would like to just enter the matching number in the other column, but FMP won't let me.  There are a few records that I have not messed up and matching ID numbers can be seen in both columns.  The records that have the missing ID numbers don't seem to be out of sync, the relationship just isn't kicking in.

      So to make matters worse, I turned off indexing in those key fields, and then turned indexing back on.  Now FMP will not allow me to re-establish the 'unique' value option for those fields. It says that indexing must be turned on, but it is. The database was created with ver 10, but now I am using 11.

        • 1. Re: Indexing - Relationship snafu
          Radcon

          I am slow, but the tortoise won the race, right?

          I deleted all my links between table occurrences.  In the index options of the key fields, I checked the box about building or creating indexes as needed and that worked for the indexing problem.  I had been trying to select 'All' for indexing; apparently FMP wants to decide how much indexing to create.  I re-established some of the relationships and now the information is looking better- Things line up & no <unrelated tables>.