AnsweredAssumed Answered

insert calculation won't work properly

Question asked by zinny on Feb 23, 2011
Latest reply on Feb 28, 2011 by zinny

Title

insert calculation won't work properly

Post

Hi,

I am attempting create a list to use in an email. I want to gather information from a series of records (the name of person and status say), dump that information into a global field and then use that global field in the email script.

I have done this sucessfully before using a loop command and then inserting calculated result into global field (with the select entire contents button off).

In fact my first script works fine, it grabs the 5 related records and makes a list in the global field that I can use later.

But my second script, copied off the first replaces the contents of the global field with each new record's information rather than adding to it.

The second script uses a different related table and has some minor tweaks before the actual loop takes place but does not in any essence do anything different (and yes, the 'select entire contents button is off)

The funny thing is when I take the go to next record (exit on last) line out of the script and run it the script adds continual copies of the one record. 

It seems like the go to next record command is affecting the select entire contents.

Has this happened to anyone else? Is there another secret button? I have tried dumping the info into the other scripts Global field but it does the same thing so I can only conclude it is something in the script. I have also shut down filemaker and that has not worked either.

Any help will be appreciated, thanks

Outcomes