2 Replies Latest reply on Jun 10, 2009 6:22 PM by PointInSpace

    Instant Web Publishing connection issues.

    BreitenbushIT

      Title

      Instant Web Publishing connection issues.

      Post

      Hello wise people,

       

      Our business uses a couple FMP Databases and our employees connect to them using IWP over our local network.  The databases are running on a Mac Mini which is devoted to just running FMP and sharing the databases over the network via IWP.  

       

      Anyways, there is a recurring issue which is seemingly becoming worse.  People will be logged in and using the databases when suddenly everyone's connections stop working.  When I try to log in a error window comes up saying that the browser (Firefox or Safari) can't connect to the server.   It appears that the IWP function simply stops (as if its not running).   We haven't been able to trace the cause of this issue and are unsure whether its an FMP issue, a network issue, or some combination of the two.  The way that always works to fix the issue is to close the databases, quit FMP, and then restart FMP and re-open the databases.  This fixes the issue every time.  The computer itself is never frozen and the network seems to be working fine.

       

      Anyone have a clue what could be causing this?  We haven't been able to replicate the issue and it happens randomly.  It seems to happen every couple days.. but sometimes happens 2-3 times in one day.   Approximately 9 users are working with the databases 7 days a week all day long.

       

      I also wonder if upgrading to FM Server would resolve this issue since I suspect that using IWP is part of the issue.

       

      Thanks in advance for any help anyone can provide,

      -shawn- 

        • 1. Re: Instant Web Publishing connection issues.
          BreitenbushIT
            

          I have done some more investigation and made some headway on this issue.  I found errors in the system logs which correspond to the times when IWP fails.  The message that appears is something along the lines of "DocWindow autoreleased with no pool in place - just leaking."

           

          I realized in troubleshooting that I have 9.0v1 installed on the serving computer and that computer is running the Leopard OS.  I think version 9.0v3 addresses certain IWP issues associated with Leopard, so I am installing the update right now.  I am hoping this clears up this issue.

           

          -shawn- 

          • 2. Re: Instant Web Publishing connection issues.
            PointInSpace
              

            Definitely be sure you're running the latest updates.  You should also really be serving off of FileMaker Server Advanced instead of FileMaker Pro, as it is *much* more robust.  You should also consider upgrading to version 10, at least on the server end of things.

             

            Note that there are a number of FileMaker hosting providers, such as ourselves:

             

            http://www.pointinspace.com/

             

            which can provide you with the resources to host your databases off FileMaker Server Advanced without having to invest in the hardware, software, etc.

             

            - John