1 2 Previous Next 18 Replies Latest reply on Jun 25, 2010 8:09 AM by philip_lamb

    Instant Web Publishing could not start on MacOS X Server 10.5.5

    josealdana_1

      Title

      Instant Web Publishing could not start on MacOS X Server 10.5.5

      Post

      Hello

      I just bought a copy of FileMaker Pro 9.0v3 and installed it on a mac mini with MacOS X Server 10.5.5 (Leopard) and I can't activate IWP, it says that "FileMaker cannot share files over the Web because Instant Web Publishing could not be started".

      I already activated FileMaker Pro, deactivated it, reinstalled, reactivated, reinstalled on top of previous installation, tried with the Web Service of the OS on and off (Apache 2.2.9), rebuilt permissions, did a custom install making sure IWP was installed, but no luck. The OS is up to date with the latest security updates. I already tried all the tips I could find in the forums. Please help.

       

      I'm running FileMaker Pro as an Admin user.


        • 1. Re: Instant Web Publishing could not start on MacOS X Server 10.5.5
          rmanook

          Hi jose,

          Thanks for posting!

           

          I'm running FileMaker Pro 9v3 on a Mac 10.5.5 and have been unable to re-create the issue (also, on other machines) based off of your troubleshooting.   To start, let's verify if there is anything on your machine that may be conflicting with IWP.

           

          Do you happen to be running iChat?  In some cases, we have seen one of the processes of iChat as the possible source of the conflict.  If so, try disabling iChat and see if the error message appears.

           

          Also, try going to System Preferences > Accounts > highlight your account name > Login Items tab.  Un-check any items listed here to help rule these applications out as possible sources of the conflict.

           

          Let me know how it works out!

           

          tsturtle

          FileMaker, inc. 

          • 2. Re: Instant Web Publishing could not start on MacOS X Server 10.5.5
            Peterb
               I have the same problem on Mac 10.4. I turned off PHP within Filemaker Server Admin and Instant Web Publishing works again but obviously without PHP. SO, I too am looking for a proper fix.
            • 3. Re: Instant Web Publishing could not start on MacOS X Server 10.5.5
              Peterb
                 Sorry, amend to above message. When it comes to selecting the appache web server I hit the skip button and this which keeps persoanl web server active.
              • 4. Re: Instant Web Publishing could not start on MacOS X Server 10.5.5
                josealdana_1
                  

                For:ts_turtle

                 

                I've also installed FileMaker Pro on several MacOS X 10.5.5 Client machines, and IWP seems to work flawlessly (as I'm writing this, IWP is working fine on my MacBook Pro with MacOS X 10.5.5), but still can not activate it on MacOS X Server 10.5.5 on the Mac mini. I'll disable iChat services and Login Items to see if this fixes the problem and get back to you. Thanks.

                • 5. Re: Instant Web Publishing could not start on MacOS X Server 10.5.5
                  amanandink
                    

                  yeah i have had the same issue too since getting filemaker pro v9.03.  we are running it on a g5 with leopard server 10.5.5 and have never got IWP to work, an error saying it cant be started. I have reinstalled, activated/deactivated, installed it over the pervious install. Nothing seems to work.

                   

                   

                  • 6. Re: Instant Web Publishing could not start on MacOS X Server 10.5.5
                    josealdana_1
                       Seems that stopping the iChat service on the Server Admin does the trick. Also I removed all sites on the web server config pane and stopped the web service. IWP is working now without a glitch. Thanks everyone.
                    • 7. Re: Instant Web Publishing could not start on MacOS X Server 10.5.5
                      TSGal

                      I recently helped a user that could not get IWP running.  We went through all the basics, making sure there was an IP address, selecting a test file and allowing access from all users.  It wasn't until we changed the default port from 80 to 591 did we have success.  Some other application was also using port 80 so there was a conflict.

                       

                      Peterb and amanandink - Any additional information (port, access, etc.) you can provide would be helpful.

                       

                      TSGal

                      FileMaker, Inc. 

                      • 8. Re: Instant Web Publishing could not start on MacOS X Server 10.5.5
                        Peterb
                          

                        Hi TSGal

                        I have scanned the port numbers on the server which are:

                         

                        21             ftp
                        497           dantz
                        548           afpovertcp
                        2399         fmpro-fdal
                        2727         mgcp-callagent
                        5003         fmpro-internal
                        5900         vnc-server
                        8020         intu-ec-svcdisc (this is supercontainer)

                         

                        I have just installed the FileMaker Server and FileMaker Server Advanced 9.0.3.326 + SSL Updater and now I can't get the instant web publishing to start up at all. even with my by-passing Apache as I metioned above.

                         

                        Port numbers sound good but I don't know how to change them and would need instructions.

                         

                        Any suggestions 

                         

                        At this stage I'm consideriing throwing myself on the mouse trap!

                         

                        Thanks

                         

                        Peter

                         

                         




                        • 9. Re: Instant Web Publishing could not start on MacOS X Server 10.5.5
                          TSGal

                          Peterb:

                           

                          Make sure you install a copy of FileMaker Pro on the server.  Then, open one of the database files, pull down the File menu and select "Sharing -> Instant Web Publishing".  Select the file in the bottom left, and then turn on Instant Web Publishing.  If there is an error, you can click the button "Advanced Options" to specify the port.  Change the port to 591 and see if IWP now turns on.

                           

                          If you are still having problems, please look at Knowledge Base article 6427.

                           

                          http://filemaker.custhelp.com/cgi-bin/filemaker.cfg/php/enduser/std_adp.php?p_faqid=6427

                           

                          This specifies all the ports needed for FileMaker Server and FileMaker Server Advanced.

                           

                          I'm hoping this gets us closer to determining what is the cause.

                           

                          TSGal

                          FileMaker, Inc. 

                          • 10. Re: Instant Web Publishing could not start on MacOS X Server 10.5.5
                            Peterb
                              

                            A SOLUTION  (From Filemaker Tech Support UK - thanks Sergio)

                             

                            Apache is unable to start or is configured incorrectly and is causing issues with FileMaker Server.

                             

                            RESOLUTION:

                             

                            Resetting Apache in Mac OS X 10.3 & 10.4:
                            Open Terminal from /Applications/Utilities/ In the Terminal window type the following:

                            sudo cp /etc/httpd/httpd.conf.default /etc/httpd/httpd.conf Restart Apache

                             

                            Resetting Apache in Mac OS X 10.5 Leopard:
                            Open Terminal from /Applications/Utilities/ In the Terminal window type the following:

                            sudo cp /etc/apache2/original/httpd.conf /etc/apache2/httpd.conf Restart Apache

                             

                            AT LAST!... this worked for me so Filemaker Server is operating OK

                             

                            THANK YOU EVERYONE

                             

                            Peter

                            • 11. Re: Instant Web Publishing could not start on MacOS X Server 10.5.5
                              saraport
                                

                              For an error like:

                              "May 13 09:38:35 stampy com.apple.launchd[1] (org.apache.httpd): Throttling respawn: Will start in 10 seconds

                              May 13 09:38:45 stampy org.apache.httpd[13029]: (48)Address already in use: make_sock: could not bind to address [::]:80

                              May 13 09:38:45 stampy com.apple.launchd[1] (org.apache.httpd[13029]): Exited with exit code: 1"

                               

                              Ah hah!  I had similar problems - and httpd wasn't running in Activity monitor, Top, etc etc.  It turns out this was a Leopard server WORKGROUP installation (this is important) and that in the Server Preferences panel for Web, all of the boxes were checked, even though the Web Service was checked "OFF". 

                               

                              When apache2 was trying to start there were conflicts between the configs that FM Server had done, and those from the Web Services

                              Short story - unchecking everything in Web Services fixed it.

                                

                              Full repair steps:

                               

                              In Terminal:

                              sudo apachectl graceful-stop

                               

                              Server Preferences ->  Web:

                              Uncheck everything, make sure Web is off.

                               

                              Server Admin (I know, WorkGroup is not fond of Server Admin):

                              Web -> Start Web 

                               

                              FileMaker Server Admin Console:

                              FM Server Overview -> Edit Server Deployment -> Enable the full IWP

                               

                              Now the web deployment should work (the conflicting wiki/blog server listening ports & address are no longer active in the Apache conf files). 

                               

                              Cheers,

                              Sara 

                              • 12. Re: Instant Web Publishing could not start on MacOS X Server 10.5.5
                                edwardslater
                                  

                                Hello All, 

                                 

                                I'm running Filemaker Pro 10 on OS X Server 10.5.6 on a Mac Pro.  

                                 

                                Ran into the same problem.  Could not, for the life of me, get IWP to work.  Kept on getting the same message as you all: "FileMaker cannot share files over the Web because Instant Web Publishing could not be started".  (By the by, seriously Filemaker?, maybe a little more explanation in your error messages next time...)

                                 

                                Anywho, one of the responses mentioned turning off iChat services within Server Admin.  So I tested it out with Filemaker and the IWP preferences windows open.  And... IT WORKED.

                                 

                                I believe some of us have Port 80 assigned as a web server, so just use port 591 (which Filemaker has registered and won't conflict).  Also, if you are like me and LOVE AND NEED iChat running off your server for your business because it is a godsend... Keep reading.

                                 

                                Just go ahead and turn iChat Services back on!!  It works and does not conflict with Filemaker IWP anymore.  Strange strange glitch.

                                 

                                Best,

                                 

                                Ed 

                                • 13. Re: Instant Web Publishing could not start on MacOS X Server 10.5.5
                                  gwbusiness
                                    

                                  I have Filemaker 10 Pro Advanced. I want to publish a database to a webhost server. I get the message that IWS could not be started.

                                   

                                  I get this message when I try to reset appache in the Terminal

                                   

                                  Last login: Fri Jun 26 06:05:13 on ttys000
                                  Gail-Wards-Computer-4:~ gailward$ sudo apachectl graceful-stop

                                  WARNING: Improper use of the sudo command could lead to data loss
                                  or the deletion of important system files. Please double-check your
                                  typing when using sudo. Type "man sudo" for more information.

                                  To proceed, enter your password, or type Ctrl-C to abort.

                                  Password:
                                  Gail-Wards-Computer-4:~ gailward$







                                  • 14. Re: Instant Web Publishing could not start on MacOS X Server 10.5.5
                                    TSGal

                                    gwbusiness:

                                     

                                    Thank you for your post.

                                     

                                    Just enter:

                                     

                                    sudo apachectl stop

                                     

                                    This will stop Apache.

                                     

                                    TSGal

                                    FileMaker, Inc. 

                                    1 2 Previous Next