7 Replies Latest reply on Dec 22, 2009 7:52 PM by tSo

    Invisible Fonts after Snow Leopard

    peepsula

      Title

      Invisible Fonts after Snow Leopard

      Post

      FM 9 user with 2 different DB's with a number of layouts.   After installing SL many layouts in both DB have fields that appear blank.  The data is there as it appears in other table layouts and the pull-down menus behave.    I can do a copy and paste and see the fields hold the data. If I add a field to the layout it will appear.  I have tried changing the color and format of the field fonts...no luck.    File appears to be fine as I can open it on my Leopard clone and everything functions properly.   I tried opening it with a trial of v. 10...same result.   I reinstalled v. 9 same result.

       

      Next step would be a clean install....but I thought I would send it up the flag pole first.

       

       

        • 1. Re: Invisible Fonts after Snow Leopard
          mrvodka
            

          As per Bruce Robertson,

           

           

          Hm, what's this, Camino won't work at all and some sites have really screwy
          text in Safari. Camino appearance preferences won't load at all. Camino
          windows won't load.

          Eventually found Library:Fonts folder with some fonts dating back to 1991 I
          think. Cleaned that out. Wow. And wow.

          Correct up to date fonts apparently make a heck of a difference in system
          speed.

          Bruce Robertson

           

           

          NOT System/Library/Fonts – leave that alone

          But user/library/fonts  and /library/fonts

           

           

           






          • 2. Re: Invisible Fonts after Snow Leopard
            peepsula
               thanks for the suggestion...I didn't have any stray font folders in my library/fonts folder
            • 3. Re: Invisible Fonts after Snow Leopard
              davidanders
                

              Font Caches can become corrupt and require deletion.

              AppleJack (unknown if Snow Leopard compatible) clears System Font Caches

              Font Explorer X clears System Font Caches and Application Font Caches (unknown SL compatible)

              Font Finangler clears Font Caches (again unknown)

               

               Google "clear font caches OSX"

              http://www.google.com/search?q=clear+font+caches+OSX 

              • 4. Re: Invisible Fonts after Snow Leopard
                peepsula
                  

                I have solved part of the problem.  It appears there are font problems that affect some programs system wide in Snow Leopard.    New fonts are added with the install which duplicate old fonts...some programs choke on the confusion, FM being one of them.  It didn't matter if it was a upgrade or a clean install of SL.

                 

                Ran Font Book, Validated all the fonts, which gives you a list of the ones that are suspect.    Then you need to check and delete the duplicate ones that are located in ~/Library/Fonts folder but not the ones in the root folder /Library/Fonts.   I did the removal, 5 different fonts from within the font book and watched them disappear in the finder window.  I had to enable a couple of fonts that the user copy (~Library) version was active and the system copy was inactive before deleting the user version.   I have seen lots of warnings about not buggering around with they system version of fonts.

                 

                Once I cleaned out the duplicates, rebooted, revalidated I had not offending fonts and my data shows up in FM 9.

                 

                The only downside is that Snow Leopard changes how some fonts are appearing in programs and on browsers...so my bold Arial 12 looks fuzzy....other people are reporting the fuzzy effects...but for now I can access my DB and get some work done....I will try to conquer the other part later. 

                • 5. Re: Invisible Fonts after Snow Leopard
                  cdowns01
                    

                  Hi... new to the forum; read your solution but it doesn't seem to work for me. My issue is invisible content in containers. I have a DB that manages a number of EPS logos. Been using it for years on my old MacBook Pro. Just bought a new MBP with Snow Leopard and ported my old FM10 file over to it, and it opens with invisible content. Very erratic too -- doesn't seem to be a rhyme or reason. On some records, the logo will show up; on others it is missing. I know the content is there b/c I can drag it to the desktop and I get a picture clipping and export it to the desktop and get a working EPS file.

                   

                  I followed your font instructions... even to the point of shutting off every font except those 30-35 or so in the System/Library folder. Restarted. No dice.

                   

                  Any other advice? Back when the Mac had an Extensions folder, I knew my way around the System Folder. Can't profess to be as comfortable mucking with System/Library/Fonts, home/Library/Fonts, and computer/Library/Fonts.

                   

                  • 6. Re: Invisible Fonts after Snow Leopard
                    sallyhamm
                      

                    My boss just bought a new computer (Mac osx 10.6 - Snow Leopard) and your solution sounded like it would work, since I found the duplicate fonts like you mentioned, so I erased all of the duplicates - but he still can't get the labels for the fields in FM to show up - the field contents are there just no labels - got anymore suggestions - like the previous person - I cleaned off all the old copies of FM and did a new reinstall also.  

                     

                    Thanks for any help you can give me. 

                    • 7. Re: Invisible Fonts after Snow Leopard
                      tSo
                        

                      Thanks Bruce!

                       

                      Per your instructions, I opened the Users/Library/Fonts folder and deleted the 1991 fonts, then restarted.

                       

                      That did the trick.