1 2 Previous Next 18 Replies Latest reply on Jun 29, 2009 9:23 AM by makita

    IWP and quicktimes

    Michael_H

      Title

      IWP and quicktimes

      Post

      Hello,

       

      I am attempting to publish a very simple test database using FMP 10 Advanced on a Mac, but I am having trouble with quicktime movies in container fields. I have put my QTs in the FMP web folder and then inserted then into the container field, but in the published web version I only get the quicktime symbol with a question mark.

      This is a "test" database because if this works, and I impress the people with the money,  I will be upgrading our FMP Server 10 to Advanced  and hosting this database there. However, if upgrading now will make this work I can justify doing it now.

       

      Any ideas?

       

      Thanks 

        • 1. Re: IWP and quicktimes
          TSGal

          Michael_H:

           

          Thank you for your post.

           

          This is what I have done....

           

          1. I launched FileMaker Pro 10 Advanced on Mac OS X 10.5.6.

           

          2. I created a database with a text field (Text) and a container field (Container).

           

          3. In "Text", I entered TSGal.

           

          4. With my cursor in Container, I pulled down the Insert menu and select "QuickTime..."

           

          5. I selected a QuickTime video that I had placed in the Web folder.

           

          6. I turned on Instant Web Publishing, and set the access to the file for All Users.

           

          7. I went to another Mac, launched Safari, entered the IP address, opened the file and the video plays.

           

          8. I went to a Dell computer running Windows XP (sp3), launched Firefox, entered the IP address, opened the file and the video plays.

           

          Let me know what steps I have done that is different than you, and I'll try to duplicate the problem here.

           

          TSGal

          FileMaker, Inc. 

          • 2. Re: IWP and quicktimes
            makita
              

            TSGal...I followed all the same steps as you mentioned below...but the one part I am not sure about is the WEB folder.

            I have my files (pdfs) and the database in the same folder on my computer).  I have  inserted the PDFs as Quicktime files into my database, but

            they don't show on the I W P version (I tried both Safari and Mozilla Firefox).  I just get a blank field.

             

            Any suggestions ?

             

            Thanks, Karen

            • 3. Re: IWP and quicktimes
              makita
                

              So...I copied all of the refereced PDF files to the WEB folder inside Filemaker Pro 10...and now on my database (not the IWP), the references all got lost...and I have to re-insert them all.

               

              And...they still don't show on the IWP...

               

              I'm pulling my hair out...really !

              • 4. Re: IWP and quicktimes
                TSGal

                makita:

                 

                I'm sorry you are having difficulty displaying images with Instant Web Publishing.

                 

                Let's start at the beginning with a new file.

                 

                1. Find a JPG file, duplicate it, and rename the duplicate copy "Test.jpg".

                 

                2. Place "Test.jpg" into the "Web" folder inside the FileMaker Pro 10 folder.

                 

                3. Create a database file, Test.fp7, with one field "IMAGE" that is a Container field.

                 

                4. Go into Browse mode, put your cursor in IMAGE, pull down the Insert menu and select "Picture..."

                 

                5. Move to the Web folder and select "Test.jpg"

                 

                6. The image should now appear in IMAGE.

                 

                7. Pull down the File menu and select "Sharing -> Instant Web Publishing..."

                 

                8. Turn on Instant Web Publishing, select Test.fp7 in the lower left corner, and set access to "All users".

                 

                9. Launch a browser on the same machine, enter the IP address, and the Instant Web Publishing page should appear.

                 

                10. Open Test.fp7.  The image should appear.

                 

                11. Log out of Instant Web Publishing.

                 

                12. Go to another machine, launch a browser, enter the IP address of the host machine, and the Instant Web Publishing page should appear.

                 

                13. Open Test.fp7.  The image should appear.

                 

                If any of these steps fail, please let me know which steps.  This will help me narrow down the possible causes.

                 

                TSGal

                FileMaker, Inc. 

                • 5. Re: IWP and quicktimes
                  makita
                    

                  TSGal...thanks so much for your post.

                   

                  I would like to clarify my problem(s).

                   

                  I have no issues with picture/image files in IWP.  They are showing up just fine.  My problem is this...

                   

                  In my Filemaker Pro 10 file, I wanted a container field that I could store PDFs in...and "see" them.

                   

                  Through my various travels through the Forums, I found that I could at least "see" the first page by inserting the PDF as a QUICKTIME file.

                   

                  YAY !

                   

                  That was really helpful, because I actually print the layout which has related reference info for a non-computer LIBRARY NOTEBOOK my boss wants to have on-hand.

                   

                  However, the Quicktime files DO NOT show up when I publish with IWP.

                   

                  I moved all of my PDF files into the WEB folder inside the Filemaker Pro application folder yesterday.  

                   

                  Not only did that NOT help with IWP....but now all of my Container Fields with PDFs show the message "The file cannot be found" until I re-link to the new location.

                   

                  So I re-linked several of them -- they show up fine in the FM Pro 10 file...but still do not show up in the IWP version.

                   

                  Hope this explanation clarifies what I am trying to accomplish.

                   

                  By the way...I have URL references for all of the PDF files...would using WEBVIEWER be an option ???

                   

                   

                  Thank you !!

                  • 6. Re: IWP and quicktimes
                    makita
                      

                    oh...and also by the way...I tried storing the PDFs in the Container field as a "file reference only" and placed the referenced file in the WEB folder...and still no luck in IWP.

                     

                    • 7. Re: IWP and quicktimes
                      makita
                        

                      some addit'l experimenting...

                       

                      when I insert the PDF files "as reference only" and they are stored in the WEB folder...

                      I see the filename show up in the container field in IWP...

                      But, when I click on the file name I get...

                       

                       HTTP: 404 Not Found

                       

                      The requested file was not found at this location.

                      /Blackberry.pdf

                       

                      • 8. Re: IWP and quicktimes
                        TSGal

                        makita:

                         

                        Thanks for the additional information.

                         

                        Using my steps from above, this is what I have continued to do:

                         

                         

                        1. I found a PDF file, aaa.pdf, and put it in the Web folder.

                         

                        2.  Launched FileMaker Pro and opened "Test.fp7".

                         

                        3. I created a new record, put my cursor in "IMAGE", pulled down the Insert menu and selected "Picture..."

                         

                        4. I inserted aaa.pdf as a reference.

                         

                        5. I created another record, put my cursor in "IMAGE", pulled down the Insert menu and selected "QuickTime...", and inserted aaa.pdf as a reference.

                         

                         

                         

                        2. Place "Test.jpg" into the "Web" folder inside the FileMaker Pro 10 folder.

                         

                        3. Create a database file, Test.fp7, with one field "IMAGE" that is a Container field.

                         

                        4. Go into Browse mode, put your cursor in IMAGE, pull down the Insert menu and select "Picture..."

                         

                        5. I sized the field to be almost a page in size.

                         

                        6. I launched Safari (4.0), entered the IP address, entered the Username and Password, and I'm able to see the PDF file and Quicktime file.  The only problem is that only the first page shows in the QuickTime movie.  This may be a limitation of the QuickTime API.

                         

                        7. I go to another Macintosh computer, launch a browser (Safari), enter the IP address and I'm able to see the PDF file and Quicktime file records.

                         

                        8. I go to a Windows machine, launch Firefox, enter the IP address.  I cannot see the PDF file, but I can see the QuickTime file.

                         

                        9. I launch Safari, and I'm able to see the PDF file, but I cannot see the QuickTime file (opposite from Firefox).

                         

                        10. Using Internet Explorer, nothing displays.

                         

                        Let me know what else to try here.

                         

                        TSGal

                        FileMaker, Inc. 

                         

                        • 9. Re: IWP and quicktimes
                          makita
                            

                          Thanks so much for all your testing.

                          I have done several most tests myself.

                          I upgraded my Safari to 4.0

                           

                          I made a test file with five container fields

                           

                          1.  Inserted a JPG as a file

                          2.  Inserted a PDF as a file

                          3.  Inserted a JPG as a picture

                          4.  Inserted a PDF as a picture

                          5.  PASTED in a JPG

                           

                          In both Safari (4.0) and Firefox (v. 5.0) 

                          the only field that SHOWS is #5...the one in which I pasted the picture in.

                           

                          The same results are with my actual file...only where I had a JPG I could COPY an PASTE does it show up thru IWP.

                           

                          I'm not sure how you got anything to show up in either Firefox or Safari.

                           

                          I am at a real loss.

                           

                          • 10. Re: IWP and quicktimes
                            makita
                              

                            ooops...let me clarify one thing.

                             

                            On the test...

                            Items 1 and 2 --

                            the filename and icons show up...but if you click on them...you just get a 404 FILE NOT FOUND message

                             

                            Also..I tried

                            6.  Inserting a PDF as a Quicktime file...

                                 In Safari...I get a big "Q"

                                 In Firefox, I get nothing 

                            • 11. Re: IWP and quicktimes
                              Michael_H
                                

                              Hello,

                               

                              I was sent this link to an version upgrade for FMP advanced 10 http://www.filemaker.com/support/updaters/fmp_10.0v1a_mac_update.html

                               

                              and it solved my problem - I can now see Quicktimes in container fields in Safari and Firefox.

                               

                              i hope this helps. 

                              • 12. Re: IWP and quicktimes
                                makita
                                  

                                Michael...

                                Thank you so much for this link...It has PARTIALLY worked (for Safari).  

                                 

                                So...TSGal...do you have any clues based on the information below.

                                 

                                #1 - Following the instructions...I installed the update, and checked for:  After completing the above steps, the FileMaker Pro function Get(ApplicationVersion) should return the string “FileMaker Web Publishing 10.0v1a” from a web client.

                                 

                                IT DOES NOT say 10.0v1a   IT SAYS 10.0v1

                                 

                                However --

                                #2 - In Safari... I can now see my PDF files inserted as QT, or my PDF files inserted as Picture -- YAY !  :-)

                                 

                                #3 - In Firefox, however (which is what the majority of people in my organization use), I can still NOT see my PDF files inserted as QT, or my PDF files inserted as Picture  :-(

                                 

                                I get a message to download a missing Plug-In.   I have downloaded the newest Adobe Acrobat and the newest Quicktime.

                                I still have the message that I am missing a Plug-In...and the Container fields for PDF as QT and PDF as Picture are blank.

                                 

                                #4 - In Windows Explorer, neither QT or Picture versions work either.

                                 

                                 

                                • 13. Re: IWP and quicktimes
                                  TSGal

                                  makita:

                                   

                                  My update is installed, and using Safari on both Mac OS X 10.5.7 and Windows XP, my Get (ApplicationVersion) displays:

                                   

                                  FileMaker Web Publishing 10.0v1a

                                   

                                  Using Firefox on a Mac, I also get the message for missing Plugins, and "No suitable plugins were found".

                                   

                                  If most of your users are going to be using Firefox, then displaying PDF files as a Picture or Quicktime (neither of which is native to PDF), then you may want to think about saving each page as a separate image.

                                   

                                  TSGal

                                  FileMaker, Inc. 

                                  • 14. Re: IWP and quicktimes
                                    makita
                                      

                                    TSGal...Thanks again for your time.

                                     

                                    I'm still a little confused, and hate giving up before I've explored all the nooks and crannies.

                                     

                                    So...even though the PDF issue is functioning in Safari - I thought it noteworthy that my Get (ApplicationVersion) displays:

                                     

                                    FileMaker Web Publishing 10.0v1  (no "a") -- WIERD, Huh...even though I've installed the update.

                                     

                                    When I try to open the file on a Windows platform...the PDF files don't show at all.

                                    and I still have no luck getting them to function with Firefox (even after downloading and trying a couple of other PDF plug in -- I still get the message to download a plugin)

                                     

                                    I am running Mac OS 10.4.11 as I am on a Power Mac G4 with 1. GHz...and a bit nervous about going to the Leopard Operating system.   Then again, you're running 10.5.7 and Firefox still won't let you do it.

                                    Is there anyone at Filemaker or maybe Mozilla we can send a note about this issue, do you think ?

                                     

                                    Thanks, Makita

                                     

                                    1 2 Previous Next