AnsweredAssumed Answered

Limited Record Access in FMP 10 vs. 9

Question asked by Marek on Jul 17, 2009
Latest reply on Jul 17, 2009 by mrvodka

Title

Limited Record Access in FMP 10 vs. 9

Post

Hi,

 

I'm trying to limit access to certain records based on the name of the user's privilege set. This works fine in FMP 9, but it seems to be broken in FMP 10.

 

I followed the FileMaker Help and tried a limited access based on the account name, setting 

Records -> Custom privs -> view -> limited to this calculation

 

Record_Created_By = Get(AccountName) 

 

This works fine in FMP 9 and 10. Now what I really need is access bases on privilege set name, so I tried:

 

privsetname = Get ( PrivilegeSetName )

 

privsetname being a field that contains the set name. This seems to work in FMP 9 but in 10 I get the weirdest results (because I tried a lot of stuff). Long story short: Although get ( privilegesetname ) returns exactly the string contained in my field privsetname, the user has no access to any record (as I said, in FMP9 he does).

 

Can anyone confirm this or give me a hint? I'v tried FMP 9 Adv and 10 (10.0v1, 10.0v3 Advanced) and I'm pretty helpless here... 

Outcomes