12 Replies Latest reply on Apr 4, 2014 6:59 AM by philmodjunk

    Links Work for Old Records, But Not New Records?????

    tkosiba

      Title

      Links Work for Old Records, But Not New Records?????

      Post

           I can populate layouts of "existing project records" with various connected tables; however, when I add new records, the new records will not link and populate the same related tables in the layouts.

           Any thoughts on why this is happening and actions I can explore to find the issue?

            

            

        • 1. Re: Links Work for Old Records, But Not New Records?????
          philmodjunk

               You'll need to describe the design of your database in much more detail. What are these relationships? What Match fields are specified? How do you add those new records?

               Did you import any of these records from another source?

          • 2. Re: Links Work for Old Records, But Not New Records?????
            tkosiba

                 I imported the "existing project records" that show up on a lookup list. These work fine and pull in simple, related, contact information.

                 Newly added projects can get added as a record (and populate on the lookup list); however, these new records do not pull up the same, related, contact information.

                 Is this the lookup table not recognizing the new records? If so, how I do I force it to recognize the related fields.

                  

            • 3. Re: Links Work for Old Records, But Not New Records?????
              philmodjunk

                   You still need to answer the rest of my questions. I need to know what tables and relationships are involved. I need to know what fields are used as match fields in those relationships.

                   

                        (and populate on the lookup list)

                   What list is that? is this a value list? Records in a table or a portal? or ???

                   And I need to know more about how you are adding new records, on what layout and how that layout is set up.

                   From what I can tell, the needed match field in the new record is not getting the correct (or perhaps not getting any) value to link it to the correct record(s) in your related table(s). But I can't even tell you where to look without knowing a lot more about your database and layout design.

              • 4. Re: Links Work for Old Records, But Not New Records?????
                tkosiba

                     I stripped this schema down to the bare bones: Two tables, project and company.

                     Regardless of what layout (i.e. project or quote for example) is used to populate new data records, I cannot draw linked records or portal information, that normally work for existing records. In other words, my primary "project table" has company info  I'm drawing; such as, contact and address from the company table. And it works for existing records, but not for new records. 

                • 5. Re: Links Work for Old Records, But Not New Records?????
                  philmodjunk

                       That helps but is still an incomplete description of what you are dealing with here.

                       Let's see if I can nail down a few more critical details.

                       You have a layout for Projects. If you enter layout mode and open Layout Setup. "projects" is the exact text selected in "Show Records From".

                       You create a new Projects record and there is no data from companies appearing on this layout.

                       Is that the situation that you have?

                  • 6. Re: Links Work for Old Records, But Not New Records?????
                    tkosiba

                         Phil: First, thanks for your patience to assist me.

                         In my Project layout, new record fields, everything based within this table can be populated. No problem. The only outside field is "company contact." This field gets auto-populated, drawing from the "contact" info from the second table.

                         Here is the rub. It only works with my original imported database and not with "new records."  

                    • 7. Re: Links Work for Old Records, But Not New Records?????
                      tkosiba

                           I created another name field in the 2nd contact table and placed it in the project table. Any old, existing records, shows this newly populated field info.

                           However, any newly created records, shows blank, and will not allow any data entry.

                           What would cause this I don't know.

                      • 8. Re: Links Work for Old Records, But Not New Records?????
                        philmodjunk

                             From the relationships shown, the only way that you layout can show data from either Company Info or Company Lookup table is if there is matching data entered/selected in the Projects::Company field. If there is no matching data in this field there will be no info appearing from either of these two table occurrences.

                             Is the Company field from Projects on your layout? Are you sure that it's from projects?

                             Enter layout mode, select the field and check and see what appears in "display data from" on the Inspector's data tab. It should read: Projects::Company. Otherwise, it is not the correct field.

                             Then, is there any data in this field?

                             Only if the data in this field matches exactly the data in the Company field of the other two Tutorial: What are Table Occurrences? will data from them appear on your layout.

                             Next thing to check if that seems correctly set up. Enter layout mode and check "Display data from" for the fields that should show company data. What do you find in Display Data from for them? They should start with either Projects::, CompanyInfo:: or Company Lookup Table::

                             If the text starts with Projects:: additional auto-enter or calculation details must be set in Manage | Database in order for that field to show company data.

                        • 9. Re: Links Work for Old Records, But Not New Records?????
                          tkosiba

                               Yes. Everything correct as you stated; however, the new records do not link. Hmmm. And to think using the Apple catalog starter solution with an added company table would cause such a headache. 

                          • 10. Re: Links Work for Old Records, But Not New Records?????
                            philmodjunk

                                 What "apple catalog starter solution"? Which one and in which version? (each version comes with a different set of starter solutions.)

                                 Exactly how are you entering data in the Projects::Company field?

                                 Are the fields that you expect to show data from the related tables fields from Projects or one of the related tables?

                            • 11. Re: Links Work for Old Records, But Not New Records?????
                              tkosiba

                                   Filemaker Pro 12 Advanced

                                   I believe I'm close. I may need a separate table for new versus imported.

                              • 12. Re: Links Work for Old Records, But Not New Records?????
                                philmodjunk

                                     Before you add a separate table, you need to identify why the project records are not matching to Company. I think that you either have no data or the wrong data in the match field.