2 Replies Latest reply on Aug 3, 2012 12:06 PM by StewartRitter

    List layout won't allow me to edit fields

    StewartRitter

      Title

      List layout won't allow me to edit fields

      Post

      Hello,

      I have a table called Clients and it has two layouts: Client Record and Client List. I can only edit the city and state fields under client list. I would like to be able to edit all the fields in client list (I can edit all fields in client records already). How do I fix it?

      Thank you!

        • 1. Re: List layout won't allow me to edit fields
          philmodjunk

          You'll need to do some checking. (Note: if you had indicate what happens exaclty when you try to edit one of these fields, the following list would be shorter.)

          Enter layout mode and click a field that does not allow you to edit it. Go to the inspector while it is still selected and check what checkboxes are selected in the Behavior section of the Data tab. If "browse mode" access is not enabled, select that option and you will likely be able to edit data in that field.

          If not, double click the field to see if button setup or specifiy field opens up. If you get button setup, the field is set up as a button and you have a choice--ungroup the field to destroy it's button setup, or don't use this layout to edit that field.

          If not, right click (option click) the field and select the script triggers menu item. If there's a scirpt trigger specified, open up that script and see if there is any code in the script that might be preventing you from editing data in the field.

          If that's not it. Note the name of the field and go to manate | Database | fields. Make sure that this is not a field of type calculation. Caldulation fields cannot be edited. If it's not a calculaiton, double click it to open Field Options. check to make sure that the "do not modify" option has been specified.

          • 2. Re: List layout won't allow me to edit fields
            StewartRitter

            Thank you! That helped a lot. It was the first option.