2 Replies Latest reply on Dec 14, 2010 4:05 PM by yomango

    Listing fields in table view don't fit

    yomango

      Title

      Listing fields in table view don't fit

      Post

      Hi. Could somebody help me with this issue? I want to list over 50 fields in a Table view but they do not seem to fit properly. The only way to fit them all is if I make them very narrow, hiding then the field labels and making it impossible to know which is which. I tried to label them on the header but the layout only allows certain number of labels. 

      Thanks

        • 1. Re: Listing fields in table view don't fit
          philmodjunk

          You can't just scroll the layout to the right as needed?

          Table view layouts do have an upper limit as to how many columns they can display. Once you reach that limit your options are to have more than one layout--each displaying a different sub set of the total number of fields in your table or possibly to set up a list view layout where you can rotate field labels side ways if needed to fit a long label with a narrow column. (That can be done with certain options for table view, but then re-sizing a column mis-aligns it to the label text.)

          Another options is to use the Modify button to add and remove columns of data as needed to control which fields are present on your layout at a given time.

           

          • 2. Re: Listing fields in table view don't fit
            yomango

            Hi. Thank your for taking time to answer. Initially, not all the fields showed because the table view gives the same width for all fields. When I tried to add fields to the table, nothing happened until I did narrow some fields. So to get them all to show on the table I narrow them to the point I can not read their respective label. And field labels do not rotate in this view, one has to rewrite them again as text but the layout only allows certain number of labels. Again, I just wanted to make sure I wasn´t doing something I should. Now I know that there´s a limitation. Thank you again.