4 Replies Latest reply on Nov 20, 2009 3:32 PM by philmodjunk

    Locking Fields

    anicolais

      Title

      Locking Fields

      Post

      Does anyone know how to lock a single field in a record so it cant be edited? I have a modified date field that I would like to lock so it cannot be edited by the users. Thanks! FM Pro 9

        • 1. Re: Locking Fields
          Jade
            

          Hi,

           

          In layout mode, select the field and then choose Field/Control>Behavior… from the Format menu. Then uncheck "In Browse Mode".

           

          You could also set this field to view only in the user's Privilege Set or Prohibit modification of the value in the field options.

           

           

          • 2. Re: Locking Fields
            philmodjunk
              
            1. Go to Manage | Database | Fields
            2. Double Click the field's definition
            3. Under the Auto Entry tab, Click "Prohibit Modification of Field During data entry."

            That locks the field everywhere.

             

            If you want to keep users from editing a field on a specific layout but not others:

             

            1. Enter Layout Mode
            2. Select the field
            3. Select Field/Control Behavior and uncheck the Allow field to be entered [] in Browse mode option.

             

            • 3. Re: Locking Fields
              nolak37
                

              is there a way to set up a field so that you can enter data only one and then lock it.

               Basicaly I want to make a button that signs the document.

               

              I have the Fields "Electronically signed by" and "Signature Date" and a button with ascript to fill in current user and date.

               

              If I do the following:

              1. Under the Auto Entry tab, Click "Prohibit Modification of Field During data entry."

              Then the button does not work and if i go with your second option:

              1. Select Field/Control Behavior and uncheck the Allow field to be entered [] in Browse mode option.

              then it works but if I press the button again a second time it opens the fields for modification.

               

              If there is another way to sign the documents that could work too.

               

              Thanks

              • 4. Re: Locking Fields
                philmodjunk
                  

                You might adapt the method described in this thread:

                 

                LOCKING FIELD

                 

                Or you might Use Field/Control | Behavior to prohibit browse mode access and write a script that uses Go To Field to place the cursor in the field. This script can check to see if access should be permitted or not.