12 Replies Latest reply on Feb 12, 2009 2:18 PM by TSGal

    Lookup Not Working On Web Interface

    MauiDave_1

      Title

      Lookup Not Working On Web Interface

      Post

      On my local machine (FM Pro 10) I have lookup working fine, when I enter an ID into a field, hit the tab key and it looks up and fills in other fields as it should.

       

      On the internet, using the web publishing, lookup doesn't work. Nothing happens when I enter the data in the field that has the relationship

       

      Any thoughts?

       

      Thanks in advance.

        • 1. Re: Lookup Not Working On Web Interface
          AndyBurtner
            

          I have some old solutions that have two related files instead of two related tables in the same file.  Even if I publish both files to the web, the relationships don't really work on the internet.  I've never tried to publish one of my newer databases to the web that have realted tables in the same file.

           

          What is your file structure?

           

          Andy

          • 2. Re: Lookup Not Working On Web Interface
            MauiDave_1
               I'm using two databases (2 files) with relationships.
            • 3. Re: Lookup Not Working On Web Interface
              TSGal

              MauiDave:

               

              Thank you for your post.

               

              The data isn't active until you press "Submit'.  At that time, the lookups should work properly.

               

              TSGal

              FileMaker, Inc. 

              • 4. Re: Lookup Not Working On Web Interface
                MauiDave_1
                  

                No, they only work locally, not in the browsers via Web Publishing. Any thoughts?

                 

                • 5. Re: Lookup Not Working On Web Interface
                  TSGal

                  MauiDave:

                   

                  Are the tables in the same file or different files?  If different, make sure the other file is also set up for full access on web publishing.

                   

                  TSGal

                  FileMaker, Inc. 

                  • 6. Re: Lookup Not Working On Web Interface
                    MauiDave_1
                       They're two different files. Both set up for full access in web publishing. 
                    • 7. Re: Lookup Not Working On Web Interface
                      TSGal

                      MauiDave:

                       

                      Thanks for the additional information.

                       

                      Please be sure to check the Auto-enter option "Prohibit modification of value during auto entry."  It will then work properly.  This is documented in our Knowledge Base as article #6179 - "Lookups are not Executed Between Two Separate Files in IWP"

                       

                      http://filemaker.custhelp.com/cgi-bin/filemaker.cfg/php/enduser/std_adp.php?p_faqid=6179

                       

                      TSGal

                      FileMaker, Inc. 

                       

                      Prohibit modification of value during auto entry. 

                      • 8. Re: Lookup Not Working On Web Interface
                        MauiDave_1
                          

                        The field with the relationship (Unit ID) can't have modification prohibited, because that's the one that we use to create the lookup.

                         

                        One of the fields that gets looked up (Property Name), I checked that box, but it didn't work on the browser.

                          

                         

                        Everything still works locally. I can send you the files if you wish, to take a look at.  

                        • 9. Re: Lookup Not Working On Web Interface
                          MauiDave_1
                            

                           

                           Ok, so the Knowledge Base article below obviously means to do this on the local machine (not in IWP) because there is no "File" menu or "Submit" button on the browser (IWP).

                          So, on the local machine, I open the file, click "File/Manage/Database" (there is no "Define > Database"), go to "Fields" and select the field that I want to have do the Lookup. The Lookup box is checked and the correct field to lookup is defined.

                          NOW, I check  Prohibit modification of value during auto entry. The only option here is to "Save Layout" (there is no "submit" button).

                           I go to my browser via the internet (IWP) and go to the database. I enter the UNIT ID and hit "Tab" but nothing fills in. It only tabs to the next empty field. 

                           ??? 

                           

                           

                           

                           

                           

                           

                          Lookups do not work properly in Instant Web Publishing (IWP) with multi-file solutions.

                          To resolve this issue:

                          1. With the database open, choose File menu > Define > Database.
                          2. In the Define Database dialog box, click the Fields tab.
                          3. Double click on the lookup field.
                          4. In the Options for Field dialog box, click the Auto-Enter tab, check the checkbox at the bottom that states Prohibit modification of value during auto entry.

                          The lookups will now work in IWP. The only draw back with this workaround is that the fields will be unmodifiable. If its necessary for the user to edit these fields a second group of fields will have to be created to act as submission fields. Create a new layout with these fields for data entry. Use a script to set the lookup fields to the data in the entry fields.

                          Note: that a lookup field will only be updated via IWP after you click on the "Submit" button to commit the record.

                          • 10. Re: Lookup Not Working On Web Interface
                            TSGal

                            MauiDave:

                             

                            Yes, "Define -> Database" was in FileMaker Pro 8, and it was replaced with "Manage -> Database" in versions 9 and 10.

                             

                            Check the option to "Prohibit modification of value during auto entry" for each of the fields you want looked up.

                             

                            Go into Instant Web Publishing.  Enter the "key" field that triggers the lookup, and then press submit.  Your lookups will then appear.  Tabbing will not trigger the lookup in Instant Web Publishing.  Only Submit.

                             

                            TSGal

                            FileMaker, Inc. 

                            • 11. Re: Lookup Not Working On Web Interface
                              MauiDave_1
                                

                              No, still doesn't work. I enter the data in the "Key" field and hit "submit". It does submit, but doesn't fill in any of the lookup fields. 

                               

                              When I go to the local machine, they fill in fine.

                               

                               

                              • 12. Re: Lookup Not Working On Web Interface
                                TSGal

                                MauiDave:

                                 

                                I have sent you a private message (top of this page - right side - X Messages) with instructions where to send your files.  I am leaving on a short trip, and I will return on Monday, so there will be a delay before getting back to you.

                                 

                                TSGal

                                FileMaker, Inc.