1 Reply Latest reply on Feb 11, 2009 7:57 AM by TSGal

    Lookup Not Working With Internet Web Publishing

    MauiDave_1

      Title

      Lookup Not Working With Internet Web Publishing

      Post


       Ok, so the Knowledge Base article below obviously means to do this on the local machine (not in IWP) because there is no "File" menu or "Submit" button on the browser (IWP).

      So, on the local machine, I open the file, click "File/Manage/Database" (there is no "Define > Database"

      NOW, I check  Prohibit modification of value during auto entry. The only option here is to "Save Layout" (there is no "submit" button).

       I go to my browser via the internet (IWP) and go to the database. I enter the UNIT ID and hit "Tab" but nothing fills in. It only tabs to the next empty field. 

       ??? 

       

       

       

       

       

       

      Lookups do not work properly in Instant Web Publishing (IWP) with multi-file solutions.

      To resolve this issue:

      1. With the database open, choose File menu > Define > Database.
      2. In the Define Database dialog box, click the Fields tab.
      3. Double click on the lookup field.
      4. In the Options for Field dialog box, click the Auto-Enter tab, check the checkbox at the bottom that states Prohibit modification of value during auto entry.

      The lookups will now work in IWP. The only draw back with this workaround is that the fields will be unmodifiable. If its necessary for the user to edit these fields a second group of fields will have to be created to act as submission fields. Create a new layout with these fields for data entry. Use a script to set the lookup fields to the data in the entry fields.

      Note: that a lookup field will only be updated via IWP after you click on the "Submit" button to commit the record.

        • 1. Re: Lookup Not Working With Internet Web Publishing
          TSGal

          MauiDave:

           

          I answered this question on another thread, but I'll repeat it here for others.

           

          Yes, Knowledge Base Article #6179 wants you to set the Field options on a local machine under FileMaker Pro, because you can't do this from Instant Web Publishing.

           

          Yes, "Define -> Database" was the option used for FileMaker Pro 8, and it has been replaced with "Manage -> Database" in versions 9 and 10.

           

          After checking the option "Prohibit modification of value during auto entry", you can click OK to get out of Field options.  You should not be in "Save Layout".

           

          Once you go to Instant Web Publishing and enter the UNIT ID field and press tab, nothing will happen until you press Submit.  Then, the lookups will execute, and you will see your values in the lookup fields.

           

          TSGal

          FileMaker, Inc.