1 Reply Latest reply on May 4, 2011 1:14 PM by philmodjunk

    lookups

    ValerieMaples

      Title

      lookups

      Post

      When I updated to FPro11, my lookups no longer worked on new records. In one case, the lookup only works if the match is a 5-digit number, not if it is 4- or 3-digits. I tried renaming the files. Relookup Field Contents works.

        • 1. Re: lookups
          philmodjunk

          From what version did you update? Are the fields (on both sides of the relationship) of type number or type text?

          This may or may not be the reason for your problem, but if you go back enough versions, there was a change in the indexing that can break relationships in newly converted files when the match fields are of type text and there are punctuation type characters in the field in one table and not in the other. The addition of an extra space in one and not the other can also break the link when they still would have worked in the older version. Editing the data in the fields so that the records have exactly the same text corrects this problem.